Why don't the values of a stock bought in an account not show up correctly in Portfolio?

I purchased a stock and entered it into the appropriate account and it recorded there correctly. But in the Portfolio view, all the values for that individual stock are wrong? I've tried to delete and reenter the purchase; and I've done Validate and Repair. Nothing works. All previous entries appear correctly in Portfolio except this recent one. What can I do to fix this?

Best Answer

Answers

  • volvogirl
    volvogirl SuperUser ✭✭✭✭
    Do you have the right number of shares and the right price per share?  You can right click on the security and edit the price history to check or add a new price.

  • q_lurker
    q_lurker SuperUser ✭✭✭✭✭
    I purchased a stock and entered it into the appropriate account and it recorded there correctly. But in the Portfolio view, all the values for that individual stock are wrong? I've tried to delete and reenter the purchase; and I've done Validate and Repair. Nothing works. All previous entries appear correctly in Portfolio except this recent one. What can I do to fix this?
    How do you have the Portfolio View Grouped -- by Account, by Security, by something else?  You likely want by Account.  

    "all values... are wrong".  Please be more specific.  What values are wrong?  Shares, quote, Cost basis?  Return?

    Have you owned that security before in that account?

    If you set the As of date back in time before the latest purchase, what values do you see?  Immediately after the latest purchase?