Quicken windows 2020 is asking for me to login but the clock just keeps spinning.

My quicken windows 2020 will not open because the quicken login just sits there. This after I updated this morning.


  • Sherlock
    Sherlock SuperUser ✭✭✭✭✭
    I suggest you perform a clean uninstall, install and update.  If you haven’t already, you may want to review: https://www.quicken.com/support/using-qcleanui-uninstall-quicken
  • thecreator
    thecreator SuperUser ✭✭✭✭✭

    Restart the computer and try logging in again, when you are back to the Desktop.
    Try the simplest approach, first.

    thecreator - User of Quicken Subscription R36.45  USA & Quicken 2017 HBRP R20.6 USA
                       Windows 10 Pro 32-Bit Build 19044.1348
                       Windows 11 Pro 64-Bit Build 22000.318
    also            Windows 10 Pro 64-Bit Build 19044.1348

    View: https://community.quicken.com/discussion/7859218/work-with-copies-of-your-actual-quicken-data-files/p1?new=1

  • Todd Bachamp
    Todd Bachamp Member ✭✭
    I started experiencing the same issue yesterday.
  • Quicken_Natalie
    Quicken_Natalie Moderator mod
    edited August 2020
    Hello @Todd Bachamp,

    Thank you for taking the time to reach out to the Community regarding this issue, although I apologize that you're experiencing these difficulties in Quicken.

    If you have not already had the chance to do so, I suggest following the steps recommended above by Sherlock and thecreator above. Please go ahead and perform a reboot of your computer, sign out and back into Quicken, and then finally, reinstall the latest patch release.

    Please let us know if any of these steps help to resolve this matter for you!

    -Quicken Natalie 

  • Yesterday I did a complete uninstall and reinstall of the Quicken Premier program, so i am now running version R28.18, build on Windows 10. This morning I encountered the spinning clock on the Quicken ID sign in window. After multiple tries, I got to an Edit option at the top of the screen, and ran the "sign in as a different user" routine everyone knows about now.

    This shows that even with the latest build, there is this problem with the sign in routine. Additionally, I got an invalid Membership Expired! message when I tried One Step Update. Eventually worked through that, but this seems to be another recurrent problem.

    Since these problems seem to have developed in the last couple of months, has
    Quicken done anything about them?

This discussion has been closed.