Home Quicken for Windows Investing (Windows)
Quicken Community is moving to Single Sign On! Starting 1/22/21, you'll sign in to the community with your Quicken ID. For more information: http://bit.ly/CommunitySSO

Problem selling shares after a stock split

jackmacjackmac Member
edited November 2020 in Investing (Windows)
Trying to enter a mutual fund sale, but Quicken disallows it because it believes there are not enough shares in the account. The fund had a 5-for-1 stock split in 1997. Entered a stock split transaction with the number of old shares (612.250) and the number of new shares (3061.250) back then. The share count matched on the subsequent account statement. Many annual distributions since, all reconciling with the account statements. The account register now shows 4951.561 shares. Now tried to enter a sell transaction for 3969.829 shares. Quicken disallows this stating it’s more than the 2253 maximum available shares of this security!?! Now what? Again, the register states there are 4951.561 shares in the account. (Quicken R30.10, Windows 10)


  • Tom YoungTom Young SuperUser ✭✭✭✭✭
    Hard to know what's going on here.  I think the first thing I'd try is to open the affected Account and then do {Ctrl}-z to recalculate all transactions to see if that sets thing to right.  If that doesn't work then do File > File Operations > Copy... and then using the copied file do File > File Operations > Validate and Repair... , making sure to also select "Rebuild investing lots."
  • q_lurkerq_lurker SuperUser ✭✭✭✭✭
    First things I suspect in such cases are:
    Trying to sell from the wrong account, and
    Trying to sell the wrong security (because of similarly named securities).
  • jackmacjackmac Member
    Tom Young - thanks for the two suggestions. Tried ctl-z and it almost worked. Was able to sell the initial 3969.829 shares, but couldn't sell all of the remaining 981.732 shares. Even though the register showed that many shares remaining, Quicken would only allow selling 509.963 shares. Even tried to do the second sell transaction in 2 steps but that didn't work either. Tried ctl-z a couple of more times, once before the second transaction and one after but it didn't help. Will try the validate and repair tomorrow.
    q_lurker - thanks for your suggestions. Did a double check of the account and security name, and they were correct.
  • jackmacjackmac Member
    Tom Young - the "Rebuild investing lots" in the "Validate and Repair" operation seems to have corrected the problem (along with many others according to the log file). This account, and 3 others, were corrupted and repaired. Thanks for the solution! :)
  • Tom YoungTom Young SuperUser ✭✭✭✭✭
    I'm glad that worked for you but I'd caution you to not simply accept willy-nilly everything reported in the log file that Quicken identifies as a problem.  For example, anytime that I validate my file I'm always told that I'm missing several stock splits, and yet every single stock split Quicken reports as "missing" is in the file.  Always investigate.
Sign In or Register to comment.