Quicken Mysteriously Deletes Many Register Records During Transaction Matching

I spend all month manually entering transactions for a credit card as they occur (a Chase card in this example), and then about once a month use the Update Transactions feature to download and match those transactions. I have discovered that if you delete a single manually entered transaction in the register while in the middle of the matching transaction process it can wreck havoc on the register, mysteriously deleting MOST of the previously manually entered transactions and presenting everything that was previously automatically matched as new unaccepted transactions. This happened last month and I discarded it as my mistake. But it happened again this month; it is clearly an issue with Quicken. I have been using this product for decades, and this feature for years. This is the first time I found a problem with its data integrity and since I am not taking any steps that I haven't taken for years, suspect it is an issue with a recent update.

Best Answer

  • UKR
    UKR SuperUser ✭✭✭✭✭
    Accepted Answer

    If you haven't rebooted Windows since you installed the latest software update, please do so now and then try Quicken again.

    Still not working?

    Let's do some "Troubleshooting 101" to ensure the Quicken software is installed and updated properly and that your data file is in good working order. Crashes or killing Quicken may damage the file.
    Please perform all the steps in this document in the order specified, even if you have done some of them before:
    Troubleshooting 101 - Fixing Software Installation and Data File Problems


Answers

  • Mark1104
    Mark1104 Member ✭✭✭✭
    I am curious - why do you manually enter the transactions if you then automate the process once per month?  Wouldn't downloading the transactions daily avoid the problem? 
  • twwva
    twwva Member
    Downloading two or three transactions daily vs. entering them manually takes about the same amount of time. Some of the manual transactions are scheduled for the future so would not show up in a daily download.

    In any case, as I look closer, there seems to be something corrupt that must be a condition for this to happen. I notice two unique things about this register:
    (1) If I try to delete any record, nothing happens, but if I then exit and reopen Quicken the record I tried to delete is gone.
    (2) There are 3 blank records that I cannot delete at the bottom of the register (register is sorted oldest to newest). If I try to enter data into those blank records or void them, it changes the date to something like 0/0/1900 and says that I need to enter a valid date. I can correct the date but when trying to enter the record it moves the cursor back to the beginning of the date field as if I still need to correct it. It remains stuck as if this record is somehow internally corrupt and there is nothing I can do about it.
  • UKR
    UKR SuperUser ✭✭✭✭✭
    Accepted Answer

    If you haven't rebooted Windows since you installed the latest software update, please do so now and then try Quicken again.

    Still not working?

    Let's do some "Troubleshooting 101" to ensure the Quicken software is installed and updated properly and that your data file is in good working order. Crashes or killing Quicken may damage the file.
    Please perform all the steps in this document in the order specified, even if you have done some of them before:
    Troubleshooting 101 - Fixing Software Installation and Data File Problems


  • twwva
    twwva Member
    Following the steps to copy the file for version R33.24 appears to have fixed my issue. Thank you!