Phantom Account in One Step Update

I used to have an HSA with Optum Bank.
Every time I do an online update, it asks me for my Optum Bank credentials. I have to hit "cancel" (and yes, I'm sure) two to three times, every time I update and each is spaced out making the update take forever.

Optum does not show up in either the "Needs Your Attention" nor the "One Step Update Complete" sections of the update summary.

When I try to edit the Optum Account online services, it shows it as "This Account is Closed". I do not know of a way to "unclose" it if that would help. I do not want to delete the account as than I would lose its history. I do not want to export and reimport it as that will probably screw up all of the transactions that are transfers between accounts.

I have unchecked "Sync to Quicken Cloud" and that does not help.

If I manually "Sync to Quicken Cloud" this same problem occurs even without a full one step update.

The account is unchecked under "Accounts for Mobile and Web" with a closed icon next to it. I tried checking it, updating (got an error) and unchecking it again. Note that this is my only closed account that appears near the top of this list. All other closed accounts fall under one of the "other" headings.

I turned off "view your finances on the quicken and mobile web apps" in preferences. This had no effect.

Please help.



  • Quicken Anja
    Quicken Anja Moderator mod
    Hello @DaveBoston,

    Thank you for reaching out to the Community to tell us about your issue, though I apologize that you are experiencing this.

    If you don't mind, we will need some additional information in order to better assist you further.

    First, could you please provide which version release of Quicken that you have currently running?
    • Help > About Quicken

    Also, how long has the account been closed? And has this issue always occurred for as long as the account has been closed, or did this just recently started happening?

    Please, check back and let us know! Thank you.
    -Quicken Anja
  • DaveBoston
    DaveBoston Member
    R33.24 Build
  • DaveBoston
    DaveBoston Member
    Also, @QuickenAnja, it seemed to start well after the account was closed. Thank you in advance for your assistance.

    Note also that I have tried to totally turn off quicken mobile/web and run a full file validation and repair. Thanks.
  • Quicken Anja
    Quicken Anja Moderator mod
    @DaveBoston Thank you for the additional information.

    To start with, if you haven't already, I suggest you create a copy of your data file in an attempt to rebuild all of the internal lists and database tables. Then, try to Validate your data file again, but in the copied file by following the instructions provided below. However, I do recommend that you also save a backup of your data file first before trying these steps (just in case).
    1. Navigate to the File menu
    2. Select File Operations
    3. Copy...
    4. Leave the presets as is and click OK
    5. Wait for the copy procedure to complete
    6. Select New Copy and click OK                                                                              If Quicken reports an error when creating the Copy file, then hold Ctrl + Shift while you click File > File Operations > Copy. When prompted to "Ignore errors that prevent file copy?" click Yes. Note: Only do this if you receive an error as this may cause some data loss.
    7. Once the newly copied file opens, navigate back to the File menu
    8. Select File Operations
    9. Validate and Repair...
    10. Select Validate file
    11. Click OK
    12. Close the Data Log
    13. Close Quicken (leave it closed for at least 5 secs)
    14. Reopen Quicken and see if the issue persists.
    You can also try to Super validate the copied file by holding down the Ctrl + Shift keys on your keyboard while selecting Validate and Repair... (step 9) which will give you the option to Super validate file instead of Validate file.

    If this does not resolve the issue, you can either switch back to your original file or restore the backup you saved prior to performing the above troubleshooting instructions (both the original and backup files should remain unaffected by the steps performed in the copied file).

    Follow the steps below to switch back to your original file
    1. Click the File menu.
    2. Look near the bottom of the options list.
    3. Select the data file you want to open. 

    Quicken will list the most recently opened data files, with a checkmark next to the file you are currently viewing.

    Let us know how it goes!

    -Quicken Anja
  • DaveBoston
    DaveBoston Member
    Per your instructions I used file operations to create a copy (noted a 3-5 issues with attachments copying but let it proceed). I then used super validation (fixed one category issue) on the copy. I then loaded the super validated copy and tried an update. Problem still exists.
  • A few updates later, the problem is still happening.
  • UKR
    UKR SuperUser ✭✭✭✭✭
    To preserve your transactions, please consider doing this:
    • First, make a backup of your data file. If something goes wrong or you don't like the results, you want to have a fallback position to restore from.
    • Create a new HSA account, but make it an "offline" checking account. Set the Opening Balance and Date to what you have in the original HSA account.
    • Now switch to the old HSA account register.
    • With the exception of its Opening Balance transaction, block-select and change all other transactions from "R"reconciled to "c"cleared in the Clr column.
    • Block-select all transactions except the Opening Balance transaction again.
    • Right-click one of the now highlighted transactions. Select "Move transactions". Select the new HSA register you created as the "move to" destination.
    • This moved all transactions and adjusted any transfer transactions to correctly point to the new HSA register, without upsetting anything ... I hope ... verify the results now ...
    • You should now be able to delete the old HSA register ... again, I hope ...
  • MoneyMike
    MoneyMike Member ✭✭
    edited October 2021
    @DaveBoston said "When I try to edit the Optum Account online services, it shows it as "This Account is Closed". I do not know of a way to "unclose" it if that would help. I do not want to delete the account as than I would lose its history. I do not want to export and reimport it as that will probably screw up all of the transactions that are transfers between accounts."

    I ran into the Phantom account in OSU as well. Unfortunately, I had to delete the closed and hidden accounts associated with the FI to correct this error. You could make a copy of your existing, then try to delete all of your closed Optum Accounts. Please reply back if that fixes your issue. Maybe Quicken can patch their software.

    By the way - Supervalidate did nothing for me either. It found no issues.
  • @UKR - THANK YOU. That seems to have worked. Note that I did get an error on move - "This Transaction is a transfer to a split" so I had to manually move about 10 transactions that were part of paychecks.