Please check internet connection and try again - Retry

BillNC
BillNC Member
I'm receiving this message every time I open quicken. "Retry" does nothing and I can't get any further. My internet is working perfectly for all other apps, and all of my quicken files are local so therefore shouldn't need an internet connection. I was on the phone with Quicken support for over an hour and verified I have the latest version. His advice was to wait 2 hours and try again. After 3 days, it still hasn't worked!

Best Answer

Answers

  • UKR
    UKR SuperUser ✭✭✭✭✭
    edited June 18

    If you are getting "Oops, something went wrong" or "Check Internet Connection" …

    • Have you recently enabled a VPN?
      If so, this might be the problem. Try turning the VPN off and see if that helps.
    • Is there a corporate or otherwise external firewall getting in the way? Contact the IT people maintaining the firewall and ask for permission.
    • Does your Antivirus software allow Quicken to connect to the Internet?
      Quicken needs to be able to establish outbound Internet connections for the program to work.
    • Try rebooting your network router. When done reboot your PC
  • [Deleted User]
    edited June 18
    @billnc - try this.

    In Windows, go into the Control Panel and click on Internet Options.  On the "Advanced" tab, scroll down to the Security section and uncheck all the SSL options and check all of the TLS options.

    The other way to get to these settings is to hit the Windows Key and search on "Internet Options".


  • einarthorsen
    einarthorsen Member
    I got this error message from Quicken 2017 Deluxe when starting it on a new Windows 11 PC with McAfee anti-virus and firewall.

    In McAfee Firewall, under "Internet Connections for Programs", I turned off "Net Guard" for Quicken.
    Quicken now works fine.
  • BillNC
    BillNC Member
    I was able to get it working by turning off the McAfee firewall! Thanks for the tip! However I couldn’t find a way to turn off Net Guard for only Quicken. I see Quicken on the list as ON but it doesn’t seem to allow editing. Any ideas?
  • [Deleted User]
    Answer ✓
    @billnc - Take a look at the Quicken support article attached regarding firewalls - 

    https://www.quicken.com/support/configuring-firewalls

    It might help you configure McAfee firewall to work with Quicken.
  • BillNC
    BillNC Member
    That fixed it, thanks! McAfee support was able to help. By editing the Quicken Firewall entry Selecting Incoming and Outgoing, and changing it from "Default" to "Open to all devices" it now works without having to turn off the entire firewall!
This discussion has been closed.