Right-click on txn shows "Report On" but doesn't do anything

Unknown
Unknown Member
edited October 2018 in Investing (Mac)
QM17 ver 4.4.2. In an investment brokerage account, I right-click on a "Walt Disney Co" transaction and select "Report On Walt Disney Co" (or any of my other stocks). But nothing happens. What am I missing?

When I select "Find Walt Disney Co", it fills in the search field with "Walt Disney Co", but shows no transactions. If I then select the magnifying glass, and select "All visible columns", it shows all the Walt Disney Co. txns. Shouldn't it assume "All visible columns" as the default?

Comments

  • John_in_NC
    John_in_NC SuperUser, Mac Beta Beta
    edited March 2017
    You would think. I can reproduce this if I had a filter set previously and then tried to report on a payee. I will not to submit this as a bug.
  • Unknown
    Unknown Member
    edited February 2018
    I had no filter set (used all defaults). How to submit a bug?
  • Unknown
    Unknown Member
    edited October 2018
    Further testing shows "Find" works in "Banking" accounts, but not in "Investing" accounts.
  • J_Mike
    J_Mike SuperUser ✭✭✭✭✭
    edited January 2017
    kenw said:

    Further testing shows "Find" works in "Banking" accounts, but not in "Investing" accounts.

    Actually, the Find does work in investing accounts - but only for Payment/Deposit (non-investment) transactions.
    I am guessing that investment transactions do not have a 'Payee' field - rather they have a separate 'Security' field in the database. The Find is not looking at the 'Security' field - (or something like that).

    IIRC, this issue did get mentioned in Beta - but obviously not addressed as yet.
    QWin & QMac (Deluxe) Subscription
    Quicken user since 1991

  • J_Mike
    J_Mike SuperUser ✭✭✭✭✭
    edited January 2017
    kenw said:

    Further testing shows "Find" works in "Banking" accounts, but not in "Investing" accounts.

    In further tinkering with this - one can get the Find to work on investment transactions;
    Select an investment transaction and execute the Find.
    The Search box is populated with the security name but you get a blank register.
    Click on the magnifying glass icon in the Search box.
    Note the default search field is Payee.
    Select Security for the search field - bingo, you get the desired results.

    This is a bit awkward and does need to be refined.
    QWin & QMac (Deluxe) Subscription
    Quicken user since 1991

  • M C Crockett
    M C Crockett Member ✭✭✭
    edited January 2017
    kenw said:

    Further testing shows "Find" works in "Banking" accounts, but not in "Investing" accounts.

    JM:  The problem appears to be related to the "string length" assigned to the "Search" field when the context sensitive "Find" and "Report" fields are used in an investment account.  For a match to occur, Quicken requires that all characters in the "Search" field must match.  It also requires that the column/field being searched must have a character length equal to or greater than the character string entered into the Search box.

    The context sensitive "Find" and "Report" queries fail in investment account registers because the "string length" is one character larger than the string entered into the "Search" field.

    In one investment account I hold shares in "COACH INCORPORATED" that can be displayed in the Security/Payee column without ellipses.  If I right-click on a transaction involving this security and select "Find" or "Report", no transactions are displayed and no report is generated.

    If I open the Securities window and open the "COACH INCORPORATED" entry for editing, I can copy the security name and paste it into the investment account's Search field.  When this is done, all the transactions involving the security are displayed.

    You can simulate what occurs in "Find" and "Report" by using the procedure in the previous paragraph and entering a space after the last character in the pasted string.  No transactions will be displayed.

    The security name is stored in the VARCHAR ZNAME field of the ZSECURITY table.  Its hard to tell if a trailing space is being retrieved or not when it is placed into the Search box; however, Search does include trailing spaces in its search.
  • J_Mike
    J_Mike SuperUser ✭✭✭✭✭
    edited January 2017
    kenw said:

    Further testing shows "Find" works in "Banking" accounts, but not in "Investing" accounts.

    I think the issue is much simpler than anything to do with string length, etc.

    Tried your Copy/Paste routine and it worked. I also observed that when I opened the drop-down list of fields to search, the All Available was checked.

    Initiating the search/find from within the register (using right-click and Find), searches only the Payee field - and nothing is found (for investment transactions).
    Changing the search field to Security or Security/Payee or All Available gives the desired results.

    The problem in investment accounts and investment transactions is with the default search field. Investment transactions do not have a Payee.
    QWin & QMac (Deluxe) Subscription
    Quicken user since 1991

  • M C Crockett
    M C Crockett Member ✭✭✭
    edited January 2017
    kenw said:

    Further testing shows "Find" works in "Banking" accounts, but not in "Investing" accounts.

    Actually, were the problem the string length, I suspect that the problem would be far more simpler to resolve.

    I did look at your discovery that the Search was being restricted to the Payee column.  Simply clicking on Security/Payee in the Search filter list allowed the "Find" option to work.

    Unfortunately, the "Report" option uses the Category Summary logic to generate the report.  This could never work as the Category Summary logic does not support filtering on Security/Payee.  It only supports filtering on Payee.

    Another complication is how you have the Category Summary logic configured.  If you disable reporting on retirement accounts, it is unlikely that it would generate a report even if it would filter on Security/Payee.
This discussion has been closed.