QWin 2017: Cannot buy more shares of a security I had already bought previously in same account

Unknown
Unknown Member
edited August 2018 in Investing (Windows)
I have an investment account and am trying to enter a Dividend Reinvestment. However Quicken won't let me indicate that the shares of the security to be bought are of the same security as those already purchased previously in the account. I have tried initially as a Dividend Reinvestment and when that failed, tried to enter just the Dividend first, then a Bought transaction, which also failed.

The first screen shot below shows the problem. I would expect a dropdown list of securities I have already bought in the Security Name field, but there is none. So I type in the name of the security, exactly as it was written in the previous successful transaction (visible at the top of the screen shot, 11/30/2016), and Quicken gives me the following error: "Please select a security whose currency matches the currency of your account."

image

Due to this roadblock, I also tried to first enter the Dividend by itself (that works), and then do a "Bought" transaction of the shares, but I encounter the same problem.

image

OK, so let's try the ticker symbol instead of the actual name:

image

Looks promising, I select the security and click Next, yielding a screen called "Add Security to Quicken", below. This is already concerning because the security is already in Quicken, in fact already in this very account already (see first screen shot, it was bought on 11/30/2016)

image

So I click Next anyways, yielding another roadblock of "You already have a security with that name":

image

Yes I do, because that's the one I'm trying to buy more shares of! Proof is when I look at the Account Overview - Holdings. The name and ticker symbol exactly match what I was trying to use in all previous steps above: 

image

Help please....?

In case this is relevant, I'm using the US version of Quicken 2017 Release 4 on Windows 10, the account is in Canadian Dollars,  the "Account Intent" is "Retirement" and has "Tax Deferred" set to "Yes". This security is also in several other investment accounts as well.


image

Comments

  • mshiggins
    mshiggins SuperUser ✭✭✭✭✭
    edited March 2017
    Neil, what currency are the other accounts that have this same security?
    Quicken user since Q1999. Currently using QW2017.
    Questions? Check out the  Quicken Windows FAQ list
  • Unknown
    Unknown Member
    edited March 2017
    He's using a US version of Quicken...and trying to deal with a Canadian investment (in $CD).  I'm thinking you can't do that in the same investment account.
  • Unknown
    Unknown Member
    edited March 2017
    Hi - thanks both of you for responding.

    mshiggins, All of the other accounts that contain that security are also based in Canadian dollars and they all only contain Canadian securities.

    GMalis1, yes this is a US version of Quicken, but I'm puzzled why it would have let me put the Canadian securities into these accounts in the first place, but now is not letting me add more of the very same securities.

    Still puzzled, thanks you whatever other help ya'll might be able to provide.
  • Unknown
    Unknown Member
    edited August 2018
    Here's how I solved this issue: add the security using Security list before you enter the transaction.  But after you add the security, edit it and change the currency type, because it will default to $US.  You must change it to $CAD, and then entering a buy transaction using that security in a C$ account will work properly. 
  • mshiggins
    mshiggins SuperUser ✭✭✭✭✭
    edited August 2018
    scottster said:

    Here's how I solved this issue: add the security using Security list before you enter the transaction.  But after you add the security, edit it and change the currency type, because it will default to $US.  You must change it to $CAD, and then entering a buy transaction using that security in a C$ account will work properly. 

    The security has a currency setting? I'm assuming that only shows if you have enabled multi currency in that data file.
    Quicken user since Q1999. Currently using QW2017.
    Questions? Check out the  Quicken Windows FAQ list
  • Unknown
    Unknown Member
    edited August 2018
    scottster said:

    Here's how I solved this issue: add the security using Security list before you enter the transaction.  But after you add the security, edit it and change the currency type, because it will default to $US.  You must change it to $CAD, and then entering a buy transaction using that security in a C$ account will work properly. 

    When I go to Investing->Security list, the table has a column called "Currency" that can be edited to be any of the currencies Quicken supports.
  • Unknown
    Unknown Member
    edited August 2018
    Another thing to remember when doing this: you will want to edit the security and change the symbol to be prefixed with "TSE:" if it trades on both Canadian and US exchanges.  The reason is, otherwise it will download the US price, and your value will show 30% (or whatever) less than it should be!  

    Of course you have to delete your old price downloaded quotes and download new quotes when you do this. 
  • mshiggins
    mshiggins SuperUser ✭✭✭✭✭
    edited August 2018
    scottster said:

    Here's how I solved this issue: add the security using Security list before you enter the transaction.  But after you add the security, edit it and change the currency type, because it will default to $US.  You must change it to $CAD, and then entering a buy transaction using that security in a C$ account will work properly. 

    From C. D. Bales:


    "When I go to Investing->Security list, the table has a column called "Currency" that can be edited to be any of the currencies Quicken supports."


    Not quite true.


    In the U.S. version of Quicken: If a security is held in a Quicken investment account, you can not change its currency - the Currency dropdown in the Security List will be grayed out.


    The U.S. version of Quicken requires that the currency of the security match the currency of any account where it is held. If you were to be able to change the currency of a security already held in a Quicken account, you would be violating that rule.
    Quicken user since Q1999. Currently using QW2017.
    Questions? Check out the  Quicken Windows FAQ list
  • Unknown
    Unknown Member
    edited August 2018
    scottster said:

    Here's how I solved this issue: add the security using Security list before you enter the transaction.  But after you add the security, edit it and change the currency type, because it will default to $US.  You must change it to $CAD, and then entering a buy transaction using that security in a C$ account will work properly. 

    The OP already said his account was denominated in C$.  Mine is also a C$ account; in the account list, the value is prefaced by a "C".  
  • mshiggins
    mshiggins SuperUser ✭✭✭✭✭
    edited August 2018
    scottster said:

    Here's how I solved this issue: add the security using Security list before you enter the transaction.  But after you add the security, edit it and change the currency type, because it will default to $US.  You must change it to $CAD, and then entering a buy transaction using that security in a C$ account will work properly. 

    From C. D. Bales:


    "The OP already said his account was denominated in C$".


    I know that, but it is immaterial to my comment.


    I pointed out that your claim that the currency of a security can be changed to fix the problem of this discussion is not true. Once a security is held in any Quicken account (which the op's security is), the currency of the security can not be changed.


    Also there's no reason to believe that changing the currency of the existing security would address the problem anyway. If the security already has the same currency as the account where the transaction is being entered, changing the currency could not help.


    Finally, the op can not use the Security List > Add Security process to address the problem: the security in question is already in the Security List (with the correct currency), and it is held in multiple Quicken accounts.


    As to the original problem:


    The fact that this particular security does not appear in the dropdown for the transaction - despite appearing to have the same currency as the account

    - suggests something about the account and/or the security may be corrupted.


    Some things the original poster could try (making sure to backup first):

    _ Test entering the transaction in some other account that has the appropriate currency.

    _ Edit the Security, completely blanking out the security name in the Security List (from position one to the end of the field), then carefully rekeying the name.

    _ Validate a Quicken Copy of the file:

    __ File > File Operations > Copy

    __ Open the Copy

    __ File > File Operations > Validate and Repair; choose to "Validate file" and "Rebuild investing lots.

    __ If the Validated Copy does not exhibit the problem, keep using that file

    _ Modify a Dividend transaction for the security to be a Reinvest Dividend transaction.

    _ Create a New (test) file, with an investment account with the characteristics of the account where the transaction is failing. Enter a Buy transaction for this specific security, then try entering a Reinvested Dividend for the security. If that works, delete all but the reinvestment transaction, export the reinvestment transaction to a QIF file, modify the QIF file to be importable

    (https://getsatisfaction.com/quickenco...), then import the QIF file into the regular Quicken file.
    Quicken user since Q1999. Currently using QW2017.
    Questions? Check out the  Quicken Windows FAQ list
This discussion has been closed.