"Quickenwindows has stopped working" when I update share price manually

Unknown
Unknown Member
edited September 2018 in Investing (Windows)
I have Quicken Deluxe 2017 updated to R15 on a Windows 10 PC. When I go into Account Overview > Holdings and manually update a share price (which I have to do because of automatic reinvesting), I get a pop-up window that says " Quickenwindows has stopped working. A program has caused the program to stop working correctly. Windows will close the program and notify you if a solution is available." I've been reloading Quicken but this keeps happening every time.

Comments

  • UKR
    UKR SuperUser ✭✭✭✭✭
    edited September 2018

    You should validate
    your Quicken data file. It may have become damaged over time or if you ever had
    crashes, hang-ups or loops while running Quicken.  Repeated crashes may eventually render a data
    file "broken beyond repair".

    Please run this procedure, skipping no steps:

    - Make a copy of your data file: Click File / File Operations / Copy.  Do not change any Copy Option settings. Save
    file under a new name in same folder as current Quicken data file.  (The Copy process appears to be performing a
    record-by-record copy of the data file and not just a simple binary image copy.
    This has been reported as recovering some otherwise not repairable
    files)

    - Open the copied file in Quicken.

    - Click File / File Operations / Validate and Repair. Click "Validate
    File" and "Rebuild investing lots", check to make sure the
    copied file is being validated, click OK. Let it run.

    - Fix any errors logged as not repaired by Quicken.

    - Now close and restart Quicken using this new file and try your failing action
    again. If it works, keep using the new file and abandon the old one.

    If that doesn't resolve the issue, you may have no recourse but to restore your
    Quicken data file from a Manual or Automatic Backup taken prior to the problem
    first occurring, if necessary going back to older backups until you find a file
    that does not exhibit these symptoms.

    https://www.quicken.com/support/how-backup-or-restore-your-quicken-data

  • Unknown
    Unknown Member
    edited November 2017
    1. Force the error.
    2. Copy the Q database onto a flash drive. 
    3. Do the end of year copy as of Jan 1, 2005. Old inactive records into archive database and new and active records into 'current' database 
    4. Test current database by changing all stock prices in two large portfolios by a penny or so. Worked 
    5. Test current database by viewing translations of stocks that I had in 2002. Worked 
    6. Conclusion:  Database size exceeded some limit.  My above actions cut the size of the data case in half. Ultimately I will not know it worked until a couple more months. 
  • Unknown
    Unknown Member
    edited November 2017
    The steps above are ultimately what worked for me.
This discussion has been closed.