Quicken Community is moving to Single Sign On! Starting 1/22/21, you'll sign in to the community with your Quicken ID. For more information: http://bit.ly/CommunitySSO

New 401k account created as single-mutual fund; buggy cash behavior

Scott Buchanan
Scott Buchanan Member ✭✭
edited March 2018 in Investing (Mac)
Environment

Version 5.5.3 (Build 55.21566.100)
macOS 10.13.3

Overview

I created a new 401k account and tried entering a manual cash deposit from my checking account, but it will not record correctly. I've seen three separate behaviors, all wrong.

As I experimented, it seems to come down to the way the account was created: automatically via the online account setup of another account at the same institution, which then discovered this account as well. Further investigation (see final section below) turned up the cause as the account being marked incorrectly as a single mutual fund account.

So there are two categories of bugs here:
  1. Incorrect "single mutual fund" configuration at account creation
  2. Odd/buggy behavior with "single mutual fund" option set
Attempt #1

I first initiated the contribution from the checking account screen by setting the category to the special transfer type. Over in the 401k, Quicken recorded it as two transactions: a stock purchase of a random security I hold in an entirely different account and a share adjustment back to zero.

I deleted the transactions before capturing any screenshots of this, though, and I haven't been able to reproduce it again.

Attempt #2

I again initiated the contribution from the checking account screen the same way:

image

This time it recorded in the 401k as a single transaction, albeit a "Buy" rather than a "Payment/Deposit" as it should have:

image

Furthermore, this was not actually reflected on the portfolio tab:

image

Attempt #3

After again deleting the incorrect transaction, I now tried to enter the contribution from the 401k account itself, this time choosing the "Payment/Deposit" type explicitly and the converse transfer category to pull it from my checking account:

image

In this case, though, I just couldn't save it at all. Clicking the save button wouldn't do anything: it didn't display any error or other message. It just did nothing at all. My only option was to hit cancel, in which case oddly a transaction was still entered, but of a blank Buy:

image

Likely Root Cause

Out of curiosity, I tried intentionally entering a fake Buy transaction of my own to see if that would work. Interestingly, when I did so I received this odd message:

image

Once I chose yes, I was able to create a successful deposit. Furthermore, even after deleting the fake buy transaction, so that the account was empty again, I was able to create a deposit without any of the above buggy behavior.

Comments

  • Scott Buchanan
    Scott Buchanan Member ✭✭
    edited March 2018
    Since I posted this, the situation has gotten worse with 5.5.4. I still see the same issue, but now the checkbox in the account settings to identify whether the account is a single account mutual fund (which was an alternate route to solving the problem) is missing. Entering a fake Buy transaction to trigger the warning dialog above is now the only route to fixing a broken account.
  • RickO
    RickO SuperUser, Mac Beta Beta
    edited March 2018
    Hi Scott,

    I see you posted this two weeks ago and never got a response. I will see if I can get someone at Quicken to look at it.

    In the mean time, I have some questions and comments.

    First, about one little part of your post: "My only option was to hit cancel, in which case oddly a transaction was still entered, but of a blank Buy."  Whenever you start a transaction entry in any kind of account and then cancel it, Quicken generally leaves a blank transaction that you have to separately delete. So the fact that when you canceled the entry, it left you a blank Buy transaction is to be expected. I'm not saying it should work that way, just that it does. So that little part is not related to your overall issue.

    I know virtually nothing about Single Mutual Fund (SMF) accounts, only that support was added for them in QM18. I don't have any SMF accounts in real life. I reverted back to 5.5.3 and created a new 401k account. I don't see a SMF option anywhere in the account settings. So I'm assuming an account can only get designated as SMF by action of connecting to the brokerage. Does that fit with your understanding?

    If possible, could you open 5.5.3 and take a screenshot of the SMF option in settings? The 5.5.3 version should be in your Trash if you haven't emptied it. Make a backup of your file first, just in case. You can move 5.5.3 from the trash to your desktop and double click it there, then delete it again when you're done. And, of course, decline to accept the update to 5.5.4 when it opens.
    Quicken Mac Subscription; Quicken Mac user since the early 90s
  • Scott Buchanan
    Scott Buchanan Member ✭✭
    edited March 2018
    I just tried opening 5.5.3, and the option wasn't there either, so maybe it's not a change in the most recent version. Now I'm not sure what the pattern is for the option being present or not is: maybe after choosing to disable the single-fund mutual fund mode, the option goes away. (As I recall, when you choose to disable single-fund mode, it gives you a warning that you "may" not be able to switch back.)

    Assuming I'm remembering correctly, I believe the checkbox appeared either to the right of or below the "type" drop-down, where the red arrow here indicates:
    image
  • Scott Buchanan
    Scott Buchanan Member ✭✭
    edited March 2018
    And yes, the accounts where this happened were created as part of connecting to a brokerage. When I first had the issue I tried creating a 401(k) account manually and could not reproduce the issue, even while simultaneously seeing it on the ones that were auto-created.
  • RickO
    RickO SuperUser, Mac Beta Beta
    edited March 2018

    I just tried opening 5.5.3, and the option wasn't there either, so maybe it's not a change in the most recent version. Now I'm not sure what the pattern is for the option being present or not is: maybe after choosing to disable the single-fund mutual fund mode, the option goes away. (As I recall, when you choose to disable single-fund mode, it gives you a warning that you "may" not be able to switch back.)

    Assuming I'm remembering correctly, I believe the checkbox appeared either to the right of or below the "type" drop-down, where the red arrow here indicates:
    image

    So, there used to be a "Single Mutual Fund" checkbox where your red arrow is pointing in your screenshot?

    This whole SMF topic is lacking documentation and transparency. Apparently, SMF is only offered or set up for certain accounts when initially set up online. And then once they have been "de-SMF'd", there is no trace that they ever were. Not the best user interface design.

    If you have time, it would be great if you could do the following to help everybody's understanding... Go to menu File > New and create a new "Start from Scratch" Quicken data file. (Your old file will not be affected.) Then set up these accounts again, and document the process, taking screenshots of everything SMF related along the way (including deactivating SMF in the settings). That would be really helpful.

    I tried to do this with my brokerage accounts, but apparently they are not of the right type to be offered SMF.

    I will volunteer to take your screenshots and turn them into a FAQ to be posted on the site to help folks with this in the future.
    Quicken Mac Subscription; Quicken Mac user since the early 90s
  • RickO
    RickO SuperUser, Mac Beta Beta
    edited March 2018

    And yes, the accounts where this happened were created as part of connecting to a brokerage. When I first had the issue I tried creating a 401(k) account manually and could not reproduce the issue, even while simultaneously seeing it on the ones that were auto-created.

    One thing about your situation still confuses me... you deactivate SMF in the settings. And now the SMF option checkbox is gone. But the problem still recurs and you have to create the fake Buy to get the "Is this the security you meant" dialog to come up to fix it still? Is this every time you try to enter a transfer or deposit into the account, even though SMF is deactivated?
    Quicken Mac Subscription; Quicken Mac user since the early 90s
  • Quicken Marcus
    Quicken Marcus Administrator, Employee ✭✭✭✭
    edited March 2018

    And yes, the accounts where this happened were created as part of connecting to a brokerage. When I first had the issue I tried creating a 401(k) account manually and could not reproduce the issue, even while simultaneously seeing it on the ones that were auto-created.

    A Single Mutual Fund/401K account doesn't have a cash balance.  At the brokerage, the transfer is automatically converted into a buy and there is never a cash position in the account.  

    The Single Mutual Fund/401K feature is to offset downloaded buy transactions with hidden transfers so the balance stays at 0 cash.  The feature is triggered by the brokerage telling us it's an SMF or 401K account and they don't send us a cash balance or the cash balance is 0 and in the case of a single mutual fund account there can only be a single security.   

    Previously, a single mutual fund account or 401k required the user to transfer cash into the account to maintain a 0 balance which was a lot of work for people.

    Scott, I think there are 2 issues going one. 

    1) The brokerage is telling us your account is a single mutual fund.  We doa bunch of checks to double check the data we are being sent but clearly something is going wrong there Quicken is misidentifying this account.

    2) It would be great to better understand the second part where you turn off the single mutual fund feature but you're still seeing a buy transaction getting created from the transfer.  This should NOT be happening since you're no longer in Single Mutual Fund mode so we're not sure what this is still happening.

    I'm going to contact you directly to see if we can work together to figure out what's going on.  Thanks for reporting this in the forums.
This discussion has been closed.