Quicken Community is moving to Single Sign On! Starting 1/22/21, you'll sign in to the community with your Quicken ID. For more information: http://bit.ly/CommunitySSO

Can add new security manually, but not with download from brokers

I can add a new security through <tools> <security list>.  But, when I download transactions from brokerages (all affected), if there is a new security I get the prompt fthat asks whether the new security matches a current security or not.  For new securities when I check "no", Quicken immediately shuts down.  This has been going on for at least a year.  QWindows (R18.14).  The workaround is to just add them manually before downloading from brokers, but it can be tedious.  I have no errors on validate and repair.

Comments

  • Bob_L
    Bob_L SuperUser ✭✭✭✭✭
    I just had that situation a few days ago and it worked fine.   There was no match to my existing securities, but a new one named by the FI that was what I wanted was included in the list so that is what I picked.  Picking no should not shut things down as you describe, but anyway be sure to look to see if the new one is in fact in the list.
    Quicken Premier Subscription, Windows 10 Home
  • UKR
    UKR SuperUser ✭✭✭✭✭

    If you haven't rebooted Windows since you installed the latest software update, please do so now and then try Quicken again.

    Still not working?

    1) Let's try some "Troubleshooting 101" to ensure the Quicken software is installed and updated properly.

    What is the exact release number for your version of Quicken?
    If clicking on Help / About Quicken does not show one of the following you are missing required software updates and, for older versions, possibly the required Intuit ID to Quicken ID conversion:

    Quicken US version:

    - 2016 ... Release R 18.4 *, https://www.quicken.com/support/quicken-2016-windows-release-notes-updates-and-mondo-patch
    - 2017 ... Release R 18.6 *, https://www.quicken.com/support/quicken-2017-windows-release-notes-updates-and-mondo-patch
    -  2018 ... upgrades to 2019 when installing the R 14.23 patch released 10/8/2018 or any later patch
    - 2019 ... Release R 18.14 *, https://www.quicken.com/support/update-and-mondo-patch-20182019-release-quicken-windows-subscription-product

    Quicken Canada version:

    - 2016 ... Release R 7 *, https://www.quicken.com/support/quicken-2016-windows-release-notes-updates-and-mondo-patch
    - 2017 ... all users should have been upgraded to 2018 already
    - 2018 ... upgrades to 2019 when installing the R 15.24 patch or any later patch
    - 2019 ... Release R 16.16 *, https://www.quicken.com/support/update-and-mondo-patch-20182019-release-quicken-windows-subscription-product

    ( * minimum required release number, may be higher, subject to change without notice)

    Please do this even if you are on the latest release already:
    Locate the US or Canada Mondo Patch file applicable to your version of Quicken in the links above.
    Download it and save it to disk.
    Open the Downloads folder. Right-click the downloaded patch file. Click "Run as Administrator" to execute the installation program.
    This will replace any Quicken software modules with a known consistent release level and, hopefully, eliminate any software corruption or errors during installation as a cause of this issue.

    Reboot Windows when done with the above and try Quicken again.

     

    2) Validate

    Validate your Quicken data file. It may have become damaged over time or if you ever had crashes, hang-ups or loops while running Quicken. Repeated crashes may eventually render a data file "broken beyond repair".

    Please run this exact procedure, skipping no steps:

    - Make a copy of your data file: Click File / File Operations / Copy.  Do not change any Copy Option settings. Save file under a new name in same folder as current Quicken data file.  (The Copy process appears to be performing a record-by-record copy of the data file and not just a simple binary image copy. This has been reported as recovering some otherwise not repairable files)
    - If Quicken reports an error creating the Copy file and you are using Q 2019 repeat the Copy process, but press and hold SHIFT and CTRL as you click File / File Operations / Copy. When prompted "Ignore errors that prevent file copy?" click "Yes".  Note: This may cause some data loss.
    - Open the copied file in Quicken.

    - Click File / File Operations / Validate and Repair. Click "Validate File" and "Rebuild investing lots", check to make sure the copied file is being validated. If you suspect that a damaged Quotes Price History causes your problems, also select "Delete investing price history".  Click OK. Let it run.

    - Fix any errors logged as not repaired by Quicken.

    - Click File / File Operations. Press and hold SHIFT+CTRL as you click Validate and Repair. The next popup should show "Supervalidate" somewhere in header or text. Click "Supervalidate File", check to make sure the copied file is being validated, click OK. Let it run. It might run for a while.
    - Again fix any errors logged as not repaired by Quicken.

    - Now close and restart Quicken using this new file and try your failing action again. If it works, keep using the new file and abandon the old one.


  • David Simel
    David Simel Member ✭✭
    Did both suggestions.  Minimal changes were deployed  Will need to wait till the next time I download a brokerage statement with a new security.

    Did the Mondo update, though I update everytime.  Was already running R18.14
    Build:  27.1.18.14

    Validate showed only: 
    QDF:
    Validating your data.
    No errors.

    QEL:
    No read errors.

    QEL:
    All internal consistency checks passed.

    [Thu Jan 31 18:54:18 2019]
    4 scheduled transactions corrected

    [Thu Jan 31 18:54:28 2019]
    Rebuilt investing lots.
    Validation has completed.

    Supervalidate showed only:
    QDF:
    Validating your data.
    No errors.

    QEL:
    No read errors.

    QEL:
    All internal consistency checks passed.

    [Thu Jan 31 19:01:38 2019]
    ---
    Corrected 2 Bought or Shares Added transactions that were incorrectly categorized as a realized gain.
    If any of these should have been for a Cover Short Sale, you should modify them. Listed:

              Date    Type                                   Account                                Security                                        Amount
        ----------    -----------------------------------    -----------------------------------    -----------------------------------    ---------------
      1     3/20/2015    Added                                  xxxxxxxxxxxxxxxxxxxxxx               xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx                    -$xxxxxxx
      2     10/2/2018    Added                                  xxxxxxxxxxxxxxxxxxxxxx               xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx            -$xxxxxxxxxx


Sign In or Register to comment.