Transferring shares between investment accounts

The "Cost Basis" for a particular investment changes when transferring between investment accounts.  I think this only happens when multiple lots have been purchased, then a partial lot sold before the transfer.  I think when the partial lot is sold, the "cost basis" used, and thus the "realized gain" calculation, is based on the total cost of the multiple lots divided by the total number of units.  This is an incorrect calculation of the "realized gain", since only a portion of the first lot was sold.  It also leaves an incorrect "amount invested" for that particular asset.  This is compounded when all remaining shares are transferred to a different investment account because they are removed using the "incorrect cost basis", but added to the new account in lots, using the original correct unit prices.  Thus by transferring shares between accounts the cost basis of the shares is changed.


Is there any way to get around this?  Because of it, the P&L statement net income plus the previous year retained earnings do NOT equal the new year retained earnings.  As well, the "realized gains" are incorrect in the year the sale was actually made.

Best Answer

  • brecarey
    brecarey Member
    Accepted Answer
    Thanks.  I found that in Canada it is required to use average cost as the cost basis. So the real problem is when Quicken does a share transfer, the "removed" side uses average cost but the "added" side adds lots at the "original cost", making the "cost basis" on the "added" side different from the "cost basis" on the "removed" side.  I have corrected this by changing the unit price on all transactions on the "added" side to the average cost on the "removed" side - a bit of work, but don't plan to transfer shares again.

Answers

  • q_lurker
    q_lurker SuperUser ✭✭✭✭✭
    That sounds to me as if you have the setting for that security established to "Use Average Cost".  That is an option that should only be available to securities typed as Mutual Fund.  It may be possible to get that erroneously for other types.  (I haven't fully played with possible variations.) 
  • That is exactly what it sounds like.  It is actually a mutual fund, should that make a difference?  Regardless, it is causing problems.  I don't see anywhere to select or de-select this option - where would it be?  It does not appear on the "Edit Security" popup.  I checked for a stock as well, and don't see it there either.  Is it only in certain versions of Quicken?  Possibly not the Canadian version?
  • Not in my version, unless this is the wrong place to look.  Maybe Canadian version doesn't have this?


  • Rocket J Squirrel
    Rocket J Squirrel SuperUser, Windows Beta ✭✭✭✭✭
    May indeed be a difference between countries. The "Use average cost" choice exists in the US version because the Internal Revenue Service allows average cost for mutual funds only. Perhaps the rules are different in Canada.
    Quicken user since version 2 for DOS, now using QWin Premier Subscription on Win10 Pro.
  • brecarey
    brecarey Member
    Accepted Answer
    Thanks.  I found that in Canada it is required to use average cost as the cost basis. So the real problem is when Quicken does a share transfer, the "removed" side uses average cost but the "added" side adds lots at the "original cost", making the "cost basis" on the "added" side different from the "cost basis" on the "removed" side.  I have corrected this by changing the unit price on all transactions on the "added" side to the average cost on the "removed" side - a bit of work, but don't plan to transfer shares again.
This discussion has been closed.