Quicken Community is moving to Single Sign On! Starting 1/22/21, you'll sign in to the community with your Quicken ID. For more information: http://bit.ly/CommunitySSO

Adjusting Sales Tax

When creating a new invoice, I can select the desired Tax Account for that invoice at the bottom of the window. However, selecting this does NOT change the tax rate shown in the invoice, only the account that the tax is placed in. Here is a quote from Help:
---------------------------------------------------------------------------
Suppose you began your business in Latah County but have picked up your first customer from Nez Perce County.

1) At the bottom of the first Nez Perce County invoice form you create, from the Tax Account list, select New.
2) In the Create Tax Account dialog, enter an account name—for example, Nez Perce - Tax—a description, and a tax rate, and click OK.

Now, whenever you have a customer from Nez Perce County, select Nez Perce - Tax from the Tax Account list on the invoice form. When you're back home in Latah County, select the tax account you've been using for that county from the Tax Account list.

--------------------------------------------------------------------------------

How do I get it to enter the tax rate that I've set for that account into the invoice? I know I can manually change the rate in the invoice, but that means I have to remember what it is for each tax account. I enter the rate in the tax account so that I shouldn't have to do this. Better yet, this should be an option that gets stored in the Customer information so that when I select the customer at the top of the form, the tax account & rate automatically populate.
Tagged:

Comments

  • wayne116
    wayne116 Member ✭✭
    I did. I created a new tax account call Tax Exempt and set that rate at zero. I will try another one with a non-zero rate and see if that makes a difference.
  • wayne116
    wayne116 Member ✭✭
    edited July 2019
    Yep, that is the problem. There is even an Edit option below the New option. When I look at a non-zero account and click Edit, the tax rate shows. When I look at the Tax Exempt account and click Edit, the tax rate box is blank. It should read 0. Zero and null are not always the same thing. In this case, zero needs to be saved as a legitimate value.
  • wayne116
    wayne116 Member ✭✭
    edited July 2019
    Your replies that I'm getting via email are not showing up on this page for the rest of the group to see.

    Ok, using .000001 instead of zero works. However, as I had said, zero is sometimes a legitimate value and shouldn't be truncated. This is one of those cases.

    Also, it would be nice if simply selecting the customer would set the sales tax account at the same time. This would require storing that information in the customer table. I don't see an option for that when I look at my list of customers. Since it would also need to be editable, it would need to be there.

    While we're at it, there are some customers whose Ship To address is always different than the mailing address. It would also be nice to have this information stored in the customer table.
This discussion has been closed.