Bug in entering transactions

When I enter an investment transaction (pressing Ctrl/Enter) the transaction enters and drops me on to the next line, but the focus of the cursor goes away instead of staying on the date field to enter the next transaction info (flickers on the date field momentarily then disappears). I have to grab the mouse and click on the date to continue instead of just continuing to type. I've tried various keystrokes, Esc, Enter, arrow keys, etc., but nothing seems to work. Very annoying and time consuming having to go grab the mouse. Using the latest subscription version of Quicken (asked me to update the last two times I opened the program). Windows 10 Pro Version 1903, Build18362.592 if that matters.

Comments

  • Klhansen
    Klhansen Member ✭✭
    No one?
    Surely I'm not holding my mouth wrong.
    Also need to ckick on the date field to start entering a transaction when switching to any account.
    This is annoying and counter productive.
  • Klhansen
    Klhansen Member ✭✭
    While I'm at it, there's another annoying feature.
    When entering prices for bonds, (which won't download with stock quotes), after entering each price, that line jumps to the bottom of the screen, and the next line is highlighted (which is good), but jumping to the bottom of the screen is not, as they're not in the same order on the brokerage statement, so I then have to scroll the screen to enter the next one on the statement. :/
    Is there a fix for that? Previous version used would maintain the screen position so all the securities would be visible, and just needed one click to get to them.
  • Klhansen
    Klhansen Member ✭✭
    Nobody??? Where are the developers who could fix this? Where are the responses? Does anyone care?
  • Klhansen
    Klhansen Member ✭✭
    I updated from Quicken Deluxe 2012, which was working fine until it started taking forever (like 30 seconds) when entering an investment transaction to let me enter the next one. This cursor focus issue is not quite as annoying, but nearly so. When opening any account, there's not a cursor waiting patiently in the date field of the first empty transaction. In fact there's no cursor anywhere until I click somewhere with the mouse.
    I just got finished reading a thread about Quicken losing cursor focus when Alt-Tabbing between applications that took nearly a year from the first post till it was resolved. The thread was 9 pages long (although with a lot of quoted content), and I believe there were only 2 or three instances of a Quicken rep posting.
  • Rocket J Squirrel
    Rocket J Squirrel SuperUser, Windows Beta ✭✭✭✭✭
    I'm replying so you know you've been seen. I can't quite tell how you're holding your mouth, though. Maybe we should FaceTime. B)
    Starting from the top, Ctrl-Enter only has effect in investment registers if the user preference "Use enter key to move between fields" is set. If that preference is unset, Ctrl-Enter does nothing for me in investment registers. It just sits there.
    Second, when that preference is set, Ctrl-Enter does indeed move focus to the Date field of the following transaction. I can't explain why it doesn't for you.
    My bond prices download from Morgan Stanley, so I have never entered them and can't help you with that use case.
    The old Alt-Tab focus problem and related focus problems have indeed been fixed, and yes, it took a long time. Are you running the latest 27.1.24.14?
    Also, your Windows 10 is out of date. Can you update to 1909, build 18363.628?
    Finally, when you lump a bunch of issues together in one thread, it becomes messy to try to respond. As you can see from my current messy answer.
    Quicken user since version 2 for DOS, now using QWin Premier Subscription on Win10 Pro.
  • Ps56k2
    Ps56k2 SuperUser ✭✭✭✭✭
    Klhansen said:
    Nobody??? Where are the developers who could fix this? Where are the responses? Does anyone care?
    just an FYI - we are all mostly peer customers here.... just saying -

    Quicken Subscription - Windows 10
  • Klhansen
    Klhansen Member ✭✭
    Hallelujah!!
    Focus is now restored to the date field on entering transactions. When I opened Quicken yesterday (2/20/20) to do some work, it loaded an update and magically, things are working better. No need to grab the mouse as the cursor waiting nicely in the date field for me to enter a new date.

    @Rocket J Squirrel. Thanks for the reply. I haven't set any preferences since default, but Ctl-enter has always worked that way for me since Quicken 2012.
    I'm a semi-luddite as far as windows updates are concerned. Microsoft tends to overwrite specific drivers and screws them up. I won't go into details, but I'm of the opinion that "if it works, don't fix it" is a good policy. I will try to keep posts to one topic in the future, as that makes sense.
    @ps56k I understand that we're "mostly" peer customers here, but there are usually company guys monitoring the forums (or at least should be).
This discussion has been closed.