Quicken Community is moving to Single Sign On! Starting 1/22/21, you'll sign in to the community with your Quicken ID. For more information: http://bit.ly/CommunitySSO

How do I delete a corrupted entry forever?

This entry is dated 2/26/2018 for 14.18. It's corrupted. I can't categorize or make any modifications without getting an error that it's corrupted, needs to be deleted and re-entered. I tried that. The re-entered transaction inherits the corrupted behavior. This entry USED TO appear on the web side but in trying to fix this I deleted both, hoping it would stop the problem, but it doesn't. The entry keeps coming back in Quicken (not the web) as corrupted, even after I delete it and even after running detect and repair. IT KEEPS COMING BACK. Why does this matter? Because periodically, I presume it happens after Quicken attempts to re-sync this with the web, all synching will STOP until I delete these entries for the 1,000th time. How do I stop this from coming back over and over?

Best Answers

Answers

  • Rocket J Squirrel
    Rocket J Squirrel SuperUser, Windows Beta ✭✭✭✭✭
    Have you tried the usual troubleshooting steps? Delete the transaction and then do the Copy & Validate.
    Quicken user since version 2 for DOS, now using QWin Premier Subscription on Win10 Pro.
  • michael7572
    michael7572 Member ✭✭
    I've gone through these steps numerous times in an effort to fix this problem, but I'm doing it again as I type.
    Here's what I know. This transaction is corrupted. I can delete it any number of times and it comes back. When it's sitting in the account NO syncing happens between the web version and the desktop version with respect to any entries I make on the web. These entries do NOT show up on the desktop as long as that corrupted entry is there. The system doesn't tell me it's there and that there's a problem unless I manually sync to the cloud, and at that point the entry comes up with either ignore (bad choice) repair (does nothing) or delete. Delete DOES delete the entry, and then on the next sync all the entries I made on the web show up on the desktop...until that entry comes back again.
    Not an option is to close out that account and open another within Quicken. First of all I want to keep the history and second, since this phantom entry keeps coming back I don't want to lose the history AND have the problem again. I just want this to go away.

    NOW: The scan completed. The rogue entry that I deleted in order to get the sync working is now back!

    Here's the segment from the log:
    ___________________________________________________________________________
    QDF:
    Validating your data.
    Fixed damaged category. Please check your category list by going to Tools>Category List.
    Repaired your data file by removing a damaged category. Please check your category list for missing categories by going to Tools>Category List.
    Quicken repaired Quicksilver XX0678 account. No action required.
    Missing split for transaction: Please enter missing data for split as needed.
    "Quicksilver XX0678" 2/26/2018 "Jimmy John's" "Order 340408530"
    Quicken repaired some transaction information. No action required.
    "Quicksilver XX0678" 2/26/2018 "Jimmy John's" "Order 340408530"

    Summary:
    Quicken repaired 1 split transaction information. No action required.
    __________________________________________________________________________

    I DELETED this entry prior to running the validate tool. After validation, the entry comes back but it comes back corrupted, as follows:

    Date Reference # Downloaded reference Downloaded ID Payee Memo Category Tag Downloaded payee Downloaded memo Notes Tax Line Item Charge Clr Payment Balance
    2/26/2018
    Jimmy John's
    Order 340408530
    Food:Dining 14.18 R
    _________________________________________________________________________
    It is categorized under Food/Dining. If I try and change this it'll tell me that it's corrupted and must be deleted and re-entered. Obviously that doesn't solve the problem because it always comes back the same way. This entry has long since been deleted on the web side so that can't possibly be the source of this phantom entry.

    In the meantime, i have to delete this entry or else syncing from the web will stop.
  • michael7572
    michael7572 Member ✭✭
    One more thing. Rather than delete that entry this time, instead I used the "void" option. I want to see if this makes a difference going forward.
  • michael7572
    michael7572 Member ✭✭
    > @michael7572 said:
    > One more thing. Rather than delete that entry this time, instead I used the "void" option. I want to see if this makes a difference going forward.

    Failed. The sync "saw" the voided entry and prevented any further syncing. It's gone until it comes back.
  • markus1957
    markus1957 SuperUser, Windows Beta Beta
    Try moving the transaction to a manually created Cash account. Then delete the Cash account.  Before re-syncing to the cloud, Reset the cloud file, do not sync before re-setting.
  • michael7572
    michael7572 Member ✭✭
    Right now the entry has been deleted. I'll re-sync and bring it back and then try your suggestion. More to come.
  • markus1957
    markus1957 SuperUser, Windows Beta Beta
    If it's gone now, I would reset the cloud file before syncing to make sure it is not hiding in the cloud file and being re-introduced by the sync.
  • michael7572
    michael7572 Member ✭✭
    I followed every step as it was written. I created a cash account, moved that bad transaction into that account, deleted that account, and reset the cloud.
    The bad transaction has returned. I'm at a loss to find WHERE this is coming from.
  • michael7572
    michael7572 Member ✭✭
    Also...I'd like to add that this transaction does NOT appear on the web version. It looks like it's "stuck" in the quicken file.
  • michael7572
    michael7572 Member ✭✭
    After deleting the rogue entry yesterday, after this morning's launch of Quicken it's back again. It doesn't show up on the web side. I need a real solution.
  • michael7572
    michael7572 Member ✭✭
    Here's an observation:
    I selected the rogue entry, did a right click and selected Edit Transaction. In Quicken the Category is Food:Dining. In the edit window it says that the category is split.
    I am unable to edit this split category or change the category.
    This is a MANUAL entry that I did after Quicken told me the original downloaded entry was corrupted. This was ages ago. It was originally a split category.
    If I perform a a search for "Jimmy John's" ALL charged transactions for this merchant come up EXCEPT the rogue entry.
  • michael7572
    michael7572 Member ✭✭
    :D First, something I missed before was to make a copy. I assumed that since I have backups of backups that wouldn't be necessary, but I found that the file size shrunk by 6mgs. Did I lose any data? Not that I can tell, which means it doesn't matter. The rogue entry was there. I deleted it. I ran the regular validate. The rouge entry was called out as corrupted and in need of deletion and recreation. I deleted it (again.) Reentry from Feb 2018 irrelevant at this point in time. I then ran the super-validate. The rouge entry did NOT come back, but a more current category got dropped from one of my entries, and I just put it back in. I then reset the cloud data. So far it's not back but I don't trust it. We'll see.
This discussion has been closed.