Quicken Community is moving to Single Sign On! Starting 1/22/21, you'll sign in to the community with your Quicken ID. For more information: http://bit.ly/CommunitySSO

Added a new mutual fund in portfolio but it will not show ROI% when I update? only shows N/A

Comments

  • Jim_Harman
    Jim_Harman SuperUser ✭✭✭✭✭
    The ROI (%) YTD and for other date ranges will show as N/A if you did not hold the security at the beginning of the period. Is this what you are seeing?
    QWin Premier subscription
  • Pachy104
    Pachy104 Member
    Yes. Bought in January, but others bought in January are showing the
    Roi%YTD when I update?
  • Jim_Harman
    Jim_Harman SuperUser ✭✭✭✭✭
    Are the securities that you bought in January that are showing ROI (%) YTD completely new, or do you perhaps also hold them in a different account?

    If you also hold them in a different account, try grouping the portfolio view by Accounts and I think you will see that holdings that are new to an account since Jan 1 will show N/A in the ROI (%) YTD column.

    If you want to see the return since purchase even if it was this year, look at the ROI (%) column.
    QWin Premier subscription
  • Jim_Harman
    Jim_Harman SuperUser ✭✭✭✭✭
    Note also that unlike the ROI (%) columns, the Return (%) columns are based on data downloaded from Quicken's quote provider (not your personal holdings and transactions) and this data is only available for publicly traded securities that have a valid ticker. This data is sometimes not available, out of date, or incorrect.

    See "Monitoring portfolio performance" in the in-product Help.
    QWin Premier subscription
This discussion has been closed.