American Express doesn't update after successful download

American Express has been working in Quicken for Mac for months, but suddenly today, after a successful download, the data didn't update in the register. I tried re-downloading multiple times, but continued to get the same outcome.

All other accounts are updating correctly.

There is nothing in the search box and the parameters are set correctly, e.g. this year. Any idea of what's going on?

Best Answer

  • RickO
    RickO SuperUser, Mac Beta Beta
    edited February 2020 Accepted Answer
    Are you using the Direct Connect method? That is known to work well with Amex and there is no extra charge for it. If you are using Quicken Connect, change over to D/C. See this:

    Choosing Direct Connect
    Quicken Mac Subscription; Quicken Mac user since the early 90s

Answers

  • Same thing is happening to me
  • MikeP
    MikeP Member ✭✭
    Same here. Nothing downloaded since January 31.
  • RickO
    RickO SuperUser, Mac Beta Beta
    edited February 2020 Accepted Answer
    Are you using the Direct Connect method? That is known to work well with Amex and there is no extra charge for it. If you are using Quicken Connect, change over to D/C. See this:

    Choosing Direct Connect
    Quicken Mac Subscription; Quicken Mac user since the early 90s
  • I took your advice and it worked. Thanks! Not sure why this stopped working out of a clear blue sky, but thanks for you suggestion on how to fix it!
  • peterbutzin
    peterbutzin Member ✭✭
    I've had the same problem, but changing to "direct connect" isn't an available option. (The choice is greyed out. The only two choices are "quicken connect" and "enter transactions manually.)

    In the past, I've often experienced issues connecting to American Express, but usually I receive an error message.

    During the past few weeks, I receive no error messages, but new transactions are not downloading.
  • RickO
    RickO SuperUser, Mac Beta Beta
    Are you using financial institution name "American Express", not one of the variations? If so, you should see Direct Connect as an option. If it's still not, click the button at the bottom left corner of the bank selection list that says "My bank is not in the list", then click Update List, then Show List. See if that fixes it.
    Quicken Mac Subscription; Quicken Mac user since the early 90s
  • lardk235
    lardk235 Member ✭✭
    Same problem - I am using direct connect and have been for years. I did disconnect and set up the account again as we were advised to do last time we had this problem and still not working
  • Henryth
    Henryth Member ✭✭
    Same issue, again!! I'll go to the Amex website and download QFX file and "import" this into Quicken.
  • I also have this issue and it started at the end of January 2020. The problem with Direct Connect is that it will not sync with the Quicken Cloud so the data isn't available on either the Mobile app or Quicken on the Web.

    Any idea when this recurring AMEX issue is finally going to be put to bed by the Quicken team?
  • Is this an AMEX issue or a Quicken issue? I'm having the same problem. AMEX had issues all of last summer, but thought there were finally fixed. Trying to decide if I goto quicken or Amex for support help.
  • Hey - I got the Fix from Quicken.
    Deactivate the download. Then go to Account NEW - pick the regular American Express (not the Skymiles) - Then select OPTIONS on the bottom right. You can Select Direct Connect here. It is not grayed out.

    Enter password and select the specific AMEX account. In the Dropdown that defaults to ADD - Instead Select the account that you want to connect. Mine works great now
  • John Hiller
    John Hiller Member ✭✭
    > @bocaboy2591 said:
    > American Express has been working in Quicken for Mac for months, but suddenly today, after a successful download, the data didn't update in the register. I tried re-downloading multiple times, but continued to get the same outcome.
    >
    > All other accounts are updating correctly.
    >
    > There is nothing in the search box and the parameters are set correctly, e.g. this year. Any idea of what's going on?

    I just started getting errors about the AMEX site not recognizing my accounts.
    I noticed if you select EDIT on the Account List screen for my accounts, that Quicken/AMEX shows a weird account number. Appeared garbled. But apparently this is how things work with AMEX.
    I wound up Deactivating online services for both of my AMEX accounts and when that is done just re-activate the online services for each account and that seems to have resolved problems downloading.
    May not help you but just so you know about this.
This discussion has been closed.