My account at quicken.com is blank- (edited to include topic)

rsierrajrNEW
rsierrajrNEW Member ✭✭
I renewed my Quick Premier 2019 Direct Download account Feb 2020. When I log in to quicken.com and click My Account, the top of my screen is BLANK. I can see nothing that identifies my account nor the Premier (Premium?) phone number.
When I tried to log into this Community support, it said my password was invalid. When I tried to setup a new community account, it said my email address & username were in use by another user (presumably, me.)
I used an alternate email address and username to set up this account. I'm caught in a catch-22. How can I contact someone at Quicken about my original problem?
Ralph Sierra

Best Answer

  • rsierrajrNEW
    rsierrajrNEW Member ✭✭
    Accepted Answer
    Two answers:
    The main one was why when I logged into my account at quicken.com I could not see my account details on the top two-thirds of the screen - it was essentially blank. The answer came when it was suggested I try it using Internet Explorer - which worked! The problem had something to do with using Google Chrome! (In my younger years I would have thought to try a different browser, but not now. I even forgot I had the phone # for Premium Support in my Contacts!)
    The second issue I'm not sure - why the password for my Community account didn't work. I think it was because it was my throw-away password - used on dozens of accounts. Probably was bought by some poor sap and he found it worked when he ran it against national websites. (As opposed to my real quicken.com password which was not compromised.)

Answers

  • UKR
    UKR SuperUser ✭✭✭✭✭
    The Community, even though it appears to be run by quicken.com, is actually run on a server farm totally separate from your Quicken ID account, with separate passwords.
    Are you sure you logged on to the correct Quicken ID or might you have purchased your renewal using a different ID?
    To get back to your usual Community ID, there should be a "forgotten password" link to help you get access again.
    In Quicken, with your current data file open, click Edit / Preferences / Quicken ID, Sync & Alerts. This will show you what the current Quicken ID is.

    If you somehow managed to establish 2 Quicken ID accounts when you only need one ...

    If you haven't done so already, I'd say it's time to call Quicken Support on the phone and request help. Do not chat with Support. They can't help. Only phone support can help you fix your Quicken ID issues.

    Quicken Support:

    • To contact Quicken Support, please use this link only:
      https://www.quicken.com/support#contact-support  and select Chat or Phone support.
      Phone support is only available during posted business hours. The phone number can be found at this website.
    • If you are eligible for Premium Support (purchased separately or included as part of your subscription to Quicken 2018+ Premier or HB&R) call the number that can be found at the top of your My Account page at https://www.quicken.com/my-account  (US) or https://www.quicken.com/canada/my-account (Canada) next to "Quicken Premium Support"  when you log in with your Quicken ID.
    • To start Chat or see the support phone number, your browser must allow popup windows from https://www.quicken.com
    • Other links or phone numbers found elsewhere on the Internet, even in some posts or emails received from other Community members, may not be from Quicken or may not be up-to-date. Use those at your own risk.
    • Unlike other so-called "Quicken support providers", the real Quicken Support is free for all currently supported versions.

  • rsierrajrNEW
    rsierrajrNEW Member ✭✭
    Accepted Answer
    Two answers:
    The main one was why when I logged into my account at quicken.com I could not see my account details on the top two-thirds of the screen - it was essentially blank. The answer came when it was suggested I try it using Internet Explorer - which worked! The problem had something to do with using Google Chrome! (In my younger years I would have thought to try a different browser, but not now. I even forgot I had the phone # for Premium Support in my Contacts!)
    The second issue I'm not sure - why the password for my Community account didn't work. I think it was because it was my throw-away password - used on dozens of accounts. Probably was bought by some poor sap and he found it worked when he ran it against national websites. (As opposed to my real quicken.com password which was not compromised.)
This discussion has been closed.