Budgeting with Tax-Free categories

Quicken Deluxe 2020 - latest update today

I am trying to create a budget that includes investment income. I have two IRA categorized accounts, and they appear under 'Retirement'. The 'Reinvest Dividend' entries show up in the budget under 'Dividends', not 'Dividends Tax-Free'. I don't see a way to change the entries to 'tax-free', so I expected Quicken to automatically categorize these as such.

How do I get these transactions to show up as tax-free income instead of taxable in a budget? Is this a bug?


Best Answer


  • John_in_NC
    John_in_NC SuperUser, Mac Beta Beta
    edited May 2020
    Hi, Jeff:

    I am not sure how you are doing this as neither Investment accounts nor transfers are supported in the budget module at this time. So, I don't know how it is capturing this income. Perhaps you aren't tracking those investment accounts within Quicken. 

    That said, even if your budget can capture them, there is no way to mark if a category is/isn't tax free for budgets. Quite honestly, I have never heard of a user being concerned about this, so I question what your end goal is. 
  • Jeff K
    Jeff K Member ✭✭
    Thanks for the reply. I used Quicken windows for decades, and have recently returned to using Quicken Mac after trying a few on-line tools for a few years. I was less than thrilled. So I'm brushing up on my Quicken skills.

    I did not know that investment accounts are not supported in the budget module. I assumed they were since the dividend transactions are included in the budget actuals.

    My goal is to see taxable income in the budget report. The category selection shows 'Dividend Tax-Free', so I assumed (maybe incorrectly) that the budget module would recognize the IRA dividends as tax-free, and not include them in regular dividends.

    Currently, the dividends from my taxable and non-taxable accounts are co-mingled in the budget report. And I need to get them separated. I think I need to create customized categories and wait for native support.

    Thanks again,
  • Jeff K
    Jeff K Member ✭✭
    I did not have the tax-free flag set on the securities. Now I do and the budget report tracks things correctly.

    This solves my issues. Thank you!
This discussion has been closed.