Quickfill Option Help (Quicken Mac)

J. Holmes
J. Holmes Member ✭✭✭
Hi All,

Before, the Quickfill rules was very helpful. It appears now that I am also seeing a "Best matches" option that clutters the drop down.

I deleted all of my Quickfill rules hoping that the Best matches options would also be deleted to no avail.

How do I disable the Best matches features so that it does not show options with the $$ amounts?

Thanks.

Comments

  • YingDave
    YingDave Member ✭✭✭✭
    I don't use the Mac version, so others may chime in who do... but is there options in Preferences "Data Entry and QuickFill" you can try to change to see it's tailored the way you like it to work?
  • J. Holmes
    J. Holmes Member ✭✭✭
    @YingDave - Thanks. I located 1 setting which didn't appear to solve the issue. The setting allows you to select 'category only' or 'all fields'.

    I am not certain if what I am observing is the expected behavior or if it is a defect.

    My preference would be to only see the category and not the options with both category + amount.
  • lhossus
    lhossus SuperUser ✭✭✭✭✭
    @J. Holmes
    Perhaps you have found this answer, as you originally posted more than a week ago. I am just catching up with old posts.

    Assuming that what you really need is for Quicken to present QuickFill choices with payee completion and category choices (but not $ amounts and memo entries):

    Go to Quicken Preferences > Register tab > QuickFill Rules (last settings at bottom of tab)
    Then enable: Automatically create rule when I edit a transaction
    and set: When saving new QuickFill Rules, save Category only

    Now when new transactions are added (or edited), a QuickFill rule will be created that has category, but not $ amount. You will have to delete the rules previously created, or just let them update as you make new transaction entries.

    Now I realize that the other stated goal was to get ride of the "Best Matches" heading. But: this is just "noise" in the display, does nothing, and does not affect the behavior you asked for.

    I enter all transactions manually, so I see the dropdown a lot, and I totally forgot about the "Best Matches" header until you mentioned it. I think this may be a defect in the dropdown, as at one time I believe the dropdown did include some not so good matches, but this seem no longer to be the case. (Or maybe it is the Categories dropdown I remember, where names "starting with", and names "containing" the entered string are displayed under separate headings.) 

    My advice is to ignore the Best Matches heading. Or send in a bug report via Help > Report a Problem ...

    Quicken Mac Subscription
    macOS Mojave 10.14.6
  • J. Holmes
    J. Holmes Member ✭✭✭
    @lhossus Thanks for the response. I didn't check the setting via Quicken Preferences > Register tab > QuickFill Rules as I did not desire rules to be created for every transaction I edit.

    I utilize the inline register option in the category field for the specific transactions that I wish to create a rule for.

    Notably, as you can see in the attached, I only have 3 QuickFill rules created. However, when I attempt to enter a new transaction, several options appear including those with $$ amounts.

    I would only expect the Transfer [Cash] selection to display, not the others. I noticed this behavior after the most recent update.
  • lhossus
    lhossus SuperUser ✭✭✭✭✭
    Interesting   :o

    What does the Payees list look like? There may be a clue there.

    Let me guess: those extra payees in the dropdown once existed in the QuickFill but you deleted them from the QuickFill list (leaving just the three you show in the Screen Shot)?

    You could try adding some additional QuickFill rules with a dummy Payee Name. This would be an attempt to substitute for the deleted QuickFills that are showing up.

    If that does not do the trick, try adding some more QuickFill rules with Payee Name of "Transfer". See what happens then.

    In any case, if as you say, you only have three QuickFill rules, then you should not be seeing so many separate Transfer rules. 


    Quicken Mac Subscription
    macOS Mojave 10.14.6
  • J. Holmes
    J. Holmes Member ✭✭✭
    @lhossus Thanks for the help. Yes, those transactions do actually exist in my register. When I started noticing the QuickFIll entries with the $$ amounts (after the latest update), I deleted all QuickFill entries and created a handful in hopes that this would resolve the issue to no avail.

    Attached are the Payees. I will continue to add more QuickFill rules over the next few days and see what happens.

    Thanks again for your help.
This discussion has been closed.