Can't Select Specific Shares When Selling Stock

Hello, I am using Quicken Premier 2020 (version 5.17.5). When I add a transaction to sell shares of stock in a brokerage account, Quicken does not show any shares available to sell.

I have tested this by entering both "add shares" or "buy" transactions and then entered sell transactions the following day. When I enter the sell transactions the shares I "added" or "bought" on the prior day do not show up as available for sale in the "specify lots" area.

I tried doing this in another brokerage account in Quicken and it worked. So, I'm guessing there is an issue with this particular brokerage account (or perhaps some sort of bug in Quicken). Has anyone experienced this before (and if so, how did you fix it)?

Any thoughts on fixing the issue? I can't find a way to move transactions from the brokerage account with this issue to a newly created account nor does there seem to be a way to copy or cut and paste transactions from the old brokerage account to the newly created account.

My last resort fall back will be to manually recreate the transactions from the old account to the new account. There are 10+ years of transactions to recreate so I would prefer to avoid doing that if possible.

Thanks in advance for your help!
Tagged:

Comments

  • Mark1104
    Mark1104 Member ✭✭✭✭
    did you try and rebuild the lots ?  (file--> file operations --> validate and repair--> rebuild investment lots. 
  • lhossus
    lhossus SuperUser ✭✭✭✭✭
    The brokerage holding this security is activated for transaction downloads, right?

    What does the Portfolio view show for number of shares?  And if you toggle the triangle before the security name in this view, does it show lots and number of shares?

    If you go to the Transactions view, and enable the Share Balance column, what has happened to the share balance over time, especially around the time you sold the security? By entering the security name in the Search field (at top of page), Quicken will make a neat report for just that security.

    What likely has happened is the brokerage has already transmitted the new number of shares held - i. e., equal to zero - as a result of your sale of the security, but the sell transaction itself has not yet been transmitted (downloaded) to Quicken.

    As a result, there should be a Placeholder transaction at the beginning of the history for this security. Probably a Remove Shares for the number of shares you are trying to sell. If you enable the Memo/Notes column, the word Placeholder will appear in that column for any Placeholder transaction.

    You can delete this Placeholder transaction. Then check that the holdings are as you expect them to be when you try to add the sell transaction. AND you can undo the deletion of the Placeholder if things don't seem right.
    Quicken Mac Subscription
    macOS Mojave 10.14.6
  • hawks28
    hawks28 Member ✭✭
    > @Mark Steinman said:
    > did you try and rebuild the lots ?  (file--> file operations --> validate and repair--> rebuild investment lots. 

    When I go to File, I don't see an option to select File Operations. I'm using Quicken Mac. Perhaps that's a Windows-only option? Thanks!
  • hawks28
    hawks28 Member ✭✭
    @lhossus, thanks for the suggestions and detail. Based on your suggestions, I think I have tracked down the issue and believe it might be user error. I still need to do some testing and further investigation but I think I erroneously specified the wrong shares of stocks in prior sales. By doing that, the shares I was expecting to be available were not available when I tried to record the recent stock sales. Thanks for the tips since they did lead me to what I think is the solution (i.e., fix the errors I introduced in prior stock sale transactions).
This discussion has been closed.