xfinity - failed set up of online biller

Weeing other similar threads recently (July/Aug), but not seeing solution.

When setting Xfinity up as online biller, I enter UID/pw and am prompted with 2FA via text. This always fails on last step.

UID/pw are good (they have been reset, and confirmed as valid in browser).

This is for Xfinity - not xfinity mobile.

Anyone on the community know where the solution is?
Thanks!

Comments

  • "Seeing" :)
  • Gary Fisher
    Gary Fisher Member ✭✭
    Quicken never downloaded statements from xfinity and now even the basic billing connection is broken and can't be re-established. As you indicated Quicken no longer handles Xfinity's 2FA correctly so it fails. Haven't seen any solutions either.
  • I had to disable two-step verification on my xfinity account. Once I did this, I was able to to successfully link eBill. Super annoying and didn't happen before, but this was the only way I could get it to work.
  • I have this exact same issue. Disappointing!
  • Quicken_Tyka
    Quicken_Tyka Alumni ✭✭✭✭
    Hello all,

    Thank you for taking the time to visit the Community to post your issue, although I apologize that you are experiencing this issue.

    At this time I would recommend contacting support directly for advanced troubleshooting steps.

    https://www.quicken.com/support#contact-support

    Quicken Care has the tools to review and research this issue further.

    Thank you,

    -Quicken Tyka

    ~~~***~~~
  • whitelight
    whitelight Member ✭✭
    good Morning Tyka,
    I have called, chatted with quicken support on issue with Xfinity for 2 months. I get the same answer - wait a week and try again or "we dont have an answer".
    Its Oct 1 and many of us cannot add xfinity to our quicken bill manager accounts. Is this some specific person in your support group that has the answer we seek?
  • N11
    N11 Member ✭✭
    > @[email protected] said:
    > I had to disable two-step verification on my xfinity account. Once I did this, I was able to to successfully link eBill. Super annoying and didn't happen before, but this was the only way I could get it to work.

    Thanks, disabling 2FA at Xfinity worked for me as well. This is not a secure work-around. Quicken, please fix this.
  • Bob.
    Bob. Member ✭✭✭✭
    N11 said:
    > @[email protected] said:
    > I had to disable two-step verification on my xfinity account. Once I did this, I was able to to successfully link eBill. Super annoying and didn't happen before, but this was the only way I could get it to work.

    Thanks, disabling 2FA at Xfinity worked for me as well. This is not a secure work-around. Quicken, please fix this.
    Are you saying that after disabling you were able to add Xfinity, or after disabling it also grabbed the latest bill due in Online Billers? If the latter I shall try. I have it as added an awaiting next bill for more than two months now. But it doesn't grab the due bill. I have not tried to Refresh the Biller as it was recommended not to.
  • Bob. said:
    Are you saying that after disabling you were able to add Xfinity, or after disabling it also grabbed the latest bill due in Online Billers? If the latter I shall try. I have it as added an awaiting next bill for more than two months now. But it doesn't grab the due bill. I have not tried to Refresh the Biller as it was recommended not to.
    @Bob. For me it was both. Only after disabling 2FA was I able to add Xfinity as an eBill. Now that it’s added with 2FA disabled, the latest bills have updated without any issues. 
  • Bob.
    Bob. Member ✭✭✭✭
    Thanks for that reply. I'll give it a try removing 2FA but leaving Xfinity as a biller as I have it there now without issue other than not fetching bills.
  • Bob.
    Bob. Member ✭✭✭✭
    Already had 2FA turned off :( But something reminded me I had to change my Xfinity password sometime in the last months - actually on 9/20! So I might have forgotten to change the password in Quicken. Though I would have hoped there would be an error thrown if so.

    Changed password, authenticated, but will not grab the bill that has been due since the first. Was worth a try.
  • jefflock
    jefflock Member ✭✭
    I am getting the same issue. When setting Xfinity up as online biller, I enter User ID and password. It then prompts me for the 2 factor via text. I enter the 2nd factor and it fails telling me the 2nd fact has expired.

    My User ID, password, 2nd factor received via text are all good.
  • Quicken_Tyka
    Quicken_Tyka Alumni ✭✭✭✭
    Hello all,

    There is a known issue with Xfinity at this time. If you have not done so already, please take a moment to visit the ongoing alert at the link below.

    https://community.quicken.com/discussion/7881655/ongoing-11-10-2020-xfinity-bill-syncing-issues#latest

    You may bookmark the alert by selecting the gold start in the top right-hand corner. This will ensure that you will be notified by email of any updates or changes.

    Thank you,
    -Quicken Tyka
    ~~~***~~~
  • Bob.
    Bob. Member ✭✭✭✭
    Xfinity just updated for me.

    I am virtually sure I had changed the password last month, but I did change it today to be sure. 3 OSU's later the bill appeared.

    So unsure if my change did the trick or if it would have updated anyway or a fluke, but reporting the experience. And, at least for me, was not 2FA.

    ~Bob