Download Quotes issue

TonyJackson
TonyJackson Windows Beta Beta
edited January 14 in Investing (Windows)
I have a large number of securities (stocks and options) in my Security List. The vast majority of these securities I no longer own. Is there a simple way to turn off Download Quotes for securities I no longer own? I've tried using the report after running the One Step Update but it does not display the securities that cannot be downloaded.

Best Answer

  • Jim_Harman
    Jim_Harman SuperUser ✭✭✭✭✭
    Accepted Answer
    OK, that is a different question.

    I agree the dialog about quotes that could not be downloaded is broken.

    If you no longer hold a security, removing it from the Watch list will also stop quote downloads. So if you don't use the Watch list, you could remove everything from it and you will only get quotes for securities you currently hold.

    It would certainly be nice it there was a "Clear Watch List" button. 

    One thing you can do to help sort through your long list of securities is to export the security list to Excel and analyze it there. You will still have to make any changes to the settings in Quicken.

    -- click the printer icon at the bottom left of the security list
    -- in the print dialog, pick Export to and ".PRN (1-2-3 compatible)". Despite the description, this will create a CSV file.
    -- When saving the file, give it a CSV extension and you should be able to open it directly in Excel.
    QWin Premier subscription

Answers

  • Jim_Harman
    Jim_Harman SuperUser ✭✭✭✭✭
    To turn off quote downloading for selected securities, go to Tools > Security List and un-check them in the Download Quotes column. While you are at it, you can remove them from the Watch List and hide them.

    Hiding securities removes them from selection lists but not from reports. 
    QWin Premier subscription
  • TonyJackson
    TonyJackson Windows Beta Beta
    Thanks Jim but as I know how to uncheck securities in the Security List. The problem is that the list is huge (100s, perhaps over 1000). Manually scrolling this list is time consuming. There doesn't seem to be a way to filter the list to securities marked for download. Even better would be a way to get a list of the securities whose quotes could not be downloaded. Really needs to be a better way to handle this.
  • Jim_Harman
    Jim_Harman SuperUser ✭✭✭✭✭
    Accepted Answer
    OK, that is a different question.

    I agree the dialog about quotes that could not be downloaded is broken.

    If you no longer hold a security, removing it from the Watch list will also stop quote downloads. So if you don't use the Watch list, you could remove everything from it and you will only get quotes for securities you currently hold.

    It would certainly be nice it there was a "Clear Watch List" button. 

    One thing you can do to help sort through your long list of securities is to export the security list to Excel and analyze it there. You will still have to make any changes to the settings in Quicken.

    -- click the printer icon at the bottom left of the security list
    -- in the print dialog, pick Export to and ".PRN (1-2-3 compatible)". Despite the description, this will create a CSV file.
    -- When saving the file, give it a CSV extension and you should be able to open it directly in Excel.
    QWin Premier subscription
  • TonyJackson
    TonyJackson Windows Beta Beta
    Thanks Jim. I'll give your suggest a try. BTW, I found that the Investing tab gave me the total number of securities I have - 3013!
    I knew it was huge, now I know just how big it is. Sigh!
  • q_lurker
    q_lurker SuperUser ✭✭✭✭✭
    As I understand the process, Quicken attempts to download quotes for securities 1) checked in the security list and 2) either owned or on the watch list.  To get the quote, the security must have valid ticker. 

    Your Quicken is only asking for 59 quotes from your 3013 securities. It seems you are trying to chase down the 12 securities Quicken is asking for that the quote supplier cannot provide.  As Jim suggests, the Watch list is likely the key. 

    I would customize a portfolio view to include security, ticker, shares, and price and include only the Watch List account. That should reveal securities not getting a quote update or that you don’t need on the list. You can then cull the list to something smaller. 

    HTH
  • TonyJackson
    TonyJackson Windows Beta Beta
    As suggested, I used the print feature to export a list of securities that I could load into Excel.
    I sorted the list in Excel to see all of the securities in the Watch List and then used the Quicken Security List to unmark all securities from the Watch List.
    Then I sorted the list in Excel to see of the securities in the Download list and updated the Quicken Security List to only mark for download the securities that I currently own (41).
    After this, I ran the One Step Update which completed with a message of "23 of 34 quotes" updated.
    Clicking on the "See a report" link produced the same useless report as before.
    As a test, I went back into the Security List and cleared all of the securities for download.
    This time I was unable to run the One Step Update as Quicken correctly reported that I had securities in Quicken that were not marked for downloading quotes.
    After updating the Security List again to only mark for download the securities that I currently own, I ran the One Step Update which completed again with a message of "23 of 34 quotes" updated and the "See a report" link produced the same useless report as before.
    I checked the price history of all 41 securities (not 23 or 34 as reported) and all have properly downloaded quotes.
    I don't know what is causing the One Step Update problem but it does not appear that it can be corrected by removing all securities from the Watch List and marking sure only valid securities are marked for download.
Sign In or Register to comment.