Why does Quicken round - 3 places to 2 places - when printing a register?

Fisherman
Fisherman Member ✭✭
Well, it's that time of year again! This is the same problem I had last February.
I was informed this occurs only with a single mutual fund IRA account type in
Quicken and it had been reported as a bug. A ticket was opened, however, there
was no ETA on when a fix can be expected. Updates were to be posted when
they became available. I was informed that fix would be complicated to implement
and was provided with some work-around solutions for the meantime.
One would be to create a register report to print instead of printing from the register directly. I have been unable to find out how to create a REGISTER REPORT
for an investment account, I have come to the conclusion that a register report
is only for spending accounts.
The other would be to change the operating system settings at Control Panel -> Region -> Formats -> Additional Settings -> Currency tab> No. of digits after decimal: This should allow the transactions to print without rounding to 2 decimal places. After following this suggestion, an insignificant zero was added to the
two place rounded decimal!
Correct Register Value: .236
Printed Register Value: .24 (Before settings change)
Printed Register Value: .240 (After settings change)
The decimal rounding occurs in Quicken and Windows can not correct it.
I have not received any updates since these work-around solutions above. The post was marked as accepted (not by me) and the discussion was closed.

Comments

  • Rocket J Squirrel
    Rocket J Squirrel SuperUser, Windows Beta ✭✭✭✭✭
    edited February 1
    Fisherman said:
    One would be to create a register report to print instead of printing from the register directly. I have been unable to find out how to create a REGISTER REPORT for an investment account, I have come to the conclusion that a register report is only for spending accounts.
    You can create a Register Report for an investment account, but you have to trick Quicken into doing it.
    From any Banking register, create a Register Report. Once the report is open, you can customize it to switch to an investment account.

    Quicken user since version 2 for DOS, now using QWin Premier Subscription on Win10 Pro.
  • Fisherman
    Fisherman Member ✭✭
    Rocket J Squirrel
    Sounds great, but I'm having a little trouble getting all the data I need. The data columns are limited for spending accounts. I need Action, Price, Shares,
    $ Amount and Share Balance columns as contained in the Quicken Investment Account Register. Can you print these in your Investment Register Report. I can't tell from your sanitized insert.

    Thanks,
  • Rocket J Squirrel
    Rocket J Squirrel SuperUser, Windows Beta ✭✭✭✭✭
    The Action appears in the Num column, the Amount is there, but the rest, as you say, are columns from banking register reports.
    I think your best bet is the Investment Transactions report.
    Quicken user since version 2 for DOS, now using QWin Premier Subscription on Win10 Pro.
  • Fisherman
    Fisherman Member ✭✭
    Rocket J Squirrel,

    The Investment Transaction Report was the first thing I tried after failing to get
    the Total Shares column of the printed Register to show 3 decimal places. The
    three place decimal is my main concert. The Investment Transaction Report
    does not allow the option of a Total Shares column. Therefore, it is useless as
    a permanent hard copy record of investment data. I have gone through over
    200 years of records to finally get them corrected and would like to not repeat
    this task again. Thanks anyway.
  • Rocket J Squirrel
    Rocket J Squirrel SuperUser, Windows Beta ✭✭✭✭✭
    edited February 7
    Edit > Preferences > Reports Only > Decimal places for prices and shares
    That should get you up to 6 decimals in reports.
    But I see what you mean about lack of Total Shares. I was surprised to see that even when told to "Subtotal by Security" it doesn't total shares. I'm not finding any single place in Quicken that does everything you want.
    200 years of records? Really?
    Quicken user since version 2 for DOS, now using QWin Premier Subscription on Win10 Pro.
  • Fisherman
    Fisherman Member ✭✭
    Rocket J Squirrel ,
    10 stocks for 20 years would be 200 years of stock records. Mom is 94 and I
    am 74. So, I think I was low balling it. REALLY!
  • q_lurker
    q_lurker SuperUser ✭✭✭✭✭
    So if this only happens for SMF IRA accounts, what is the drawback to undoing the SMF setting?
  • Fisherman
    Fisherman Member ✭✭
    I tried that. When I printed the register it did not contain the Total Shares Column at all. Now we know why Quicken says it only happens with SMF account. It seems to be the only one that prints the column at all. My main concern all along has been to be able to print registers with total shares having the correct decimal places (not rounded to 2 places) included.
    Thanks for the thought anyway.

    I'm hoping someone in the community can come up with a solution.
    I've been waiting on Quicken for a year. Haven't heard from
    them since they told me they put in a ticket and it would be a difficult fix.
    They sent two suggested workarounds which were both invalid.
  • Rocket J Squirrel
    Rocket J Squirrel SuperUser, Windows Beta ✭✭✭✭✭
    edited February 11
    The investment register has a "Share Bal" column which shows total shares to 6 decimal places as of the transaction date.
    Too bad it doesn't print those numbers.
    EDIT: Sorry, I see this was covered earlier in the thread. I'd be willing to call it a bug that printing the register results in a printout which is not WYSIWYG.
    Quicken user since version 2 for DOS, now using QWin Premier Subscription on Win10 Pro.
  • Fisherman
    Fisherman Member ✭✭
    Rocket J Squirrel,
    I'm glad someone finally sees my problem. I can not find a way around this.
    I hope more people ask about this bug. I would like Quicken to take this seriously and provide a reasonable response. I hope Quicken doesn't just
    consider this over and close this discussion again.
    Thanks for the posting. At least I don't feel like a total idiot on a desert island.