How do I solve a periodic mouse wheel scrolling glitch?

I have been experiencing an increasing problem with scrolling in my registers using my mouse wheel. Usually I can scroll one entry at a time. But occasionally, a small nudge in the mouse wheel will result in rapid scrolling, up or down, of dozens to hundreds of entries. Click scrolling on the scroll bar continues to work properly. Exiting Quicken and restarting resolves the problem, at least for a time. This scrolling problem is unique to Quicken.

Comments

  • Ps56k2
    Ps56k2 SuperUser ✭✭✭✭✭
    What version - as there was a recent issue with one of the R31.xx releases
    ... Help --> About Quicken ?
    Quicken Subscription - Windows 10
  • Crotalus
    Crotalus Member
    R 3.1.8 Build 27.1.31.8. But this issue has been ongoing for the last couple of years. It seems to be getting worse with the last couple of versions.
  • UKR
    UKR SuperUser ✭✭✭✭✭
    Do you have another mouse available that you can use instead of the current one? Maybe there's something wrong with the mouse ... just shooting in the dark here ...
  • Crotalus
    Crotalus Member
    Thanks. I'll try that. I hadn't before this because I've never had any problems with scrolling outside Quicken.
  • gs_
    gs_ Member ✭✭✭
    Quicken Windows Canada R28.15 Build 27.128.15

    Logitech Smooth Scrolling needs to be disabled if memory serves me correctly. It was happening on an older machine and I "fixed" it - then when I got a new machine it "came back". This thread reminded me of the issue (which was intermittent, but a nuisance when it appeared) and I loaded Logitech Options, went to Scrolling and found Smooth Scrolling enabled. I've just disabled it and will report back if the problem appears to be fixed (for me).
  • Crotalus
    Crotalus Member
    I just turned off smooth scrolling. Also, latest Quicken version R31.12 downloaded this morning. Release notes indicate it is supposed to fix scrolling problem. The wait begins.
  • gs_
    gs_ Member ✭✭✭
    edited February 7
    My "fast scrolling" issue appears to have been fixed by the change I made.
    I loaded Logitech Options, went to Scrolling and found Smooth Scrolling enabled. I've just disabled it

  • peterhouser
    peterhouser Member
    I have this same issue Quicken Deluxe Subscription R33.24 27.1.33.24 Windows 10. I use a Microsoft Surface Precision Mouse. Mouse wheel scrolls too fast. I don't have this problem in other software.
  • UKR
    UKR SuperUser ✭✭✭✭✭
    I have this same issue Quicken Deluxe Subscription R33.24 27.1.33.24 Windows 10. I use a Microsoft Surface Precision Mouse. Mouse wheel scrolls too fast. I don't have this problem in other software.

    Have you looked into the settings in Windows Control Panel / Mouse / Wheel tab? Maybe there's something you can adjust.
    Also check if there's an accumulation of dust or hair inside the mouse ...
  • Crotalus
    Crotalus Member
    Problem per "gsx" was solved by turning off mouse smooth scrolling. This solution worked for me too. My only problem now is that scrolling is herky-jerky on browsers and other apps. So I turn smooth scrolling on as default and just shut it off when I'm using Quicken. Hope this helps.
This discussion has been closed.