LL Bean Mastercard Problem

For some reason, the online connection to LL Bean Mastercard broke, and wanted me to re-connect. When I try to re-establish, it wants to add "llbeanvisa.com" This was the Barclay Bank site that was used before LL Bean Cards were transferred to Citi Retail Services, which was years ago, and obviously does not work.

How to I re-add this? It worked yesterday!

Best Answer

  • GeoffG
    GeoffG SuperUser ✭✭✭✭✭
    Accepted Answer
    Not sure what you mean by broke? Did you you use Update Now (advised) or did you deactivate your account (ill-advised).
    When I set out to Add New account and type LL, I get the following screen.

    This is the correct institution and should take you when setup to this screen.

    Even though it is managed by Citi, it does not appear as the name.
    user since '92 | Quicken Windows Premier - Subscription | Windows 10 Pro version 21H1

Answers

  • GeoffG
    GeoffG SuperUser ✭✭✭✭✭
    Accepted Answer
    Not sure what you mean by broke? Did you you use Update Now (advised) or did you deactivate your account (ill-advised).
    When I set out to Add New account and type LL, I get the following screen.

    This is the correct institution and should take you when setup to this screen.

    Even though it is managed by Citi, it does not appear as the name.
    user since '92 | Quicken Windows Premier - Subscription | Windows 10 Pro version 21H1
  • PCoppinger
    PCoppinger Member ✭✭
    You're right. When I say something broke, I was suddenly getting rejected by the bank server, probably because of an expired authorization or something, which required me to reset the online services using just this window.

    I do recall having a rather difficult time when LL Bean moved from Barclay to Citi, and so when the link appeared to be to the Visa/Barclay server, I was looking for whatever I used to fix it last time.

    You are correct that although the link says "llbeanvisa.com" it does indeed connect to the Citi/MasterCard server. Thanks