How to Add Bank of America Card to Quicken (Allegiant, Alaska)

I got a new Allegiant Airlines credit card, through Bank of America. However, I cannot add it, neither with Express Web Connect or Direct Connect. It keeps saying user name / password not working. Sometimes it doesn't even send me the PIN. I know I had similar problems with my wife's Alaska Airlines card, also through Bank of America, but I don't use that card so no matter. I've seen some threads that Bank of America doesn't work too well with Quicken, but wanted to confirm with others here before I gave up.

Answers

  • BK
    BK Member ✭✭✭✭
    Hi @MintUserNew , I don't have any BofA cards to verify this for you, but on their banking site, under Profile & Settings > Security center, there is a "3rd Party Site Access" tab that one may have to visit and take some action to enable access to Quicken.  Some financial institutions have this requirement that want you to enable access to 3rd party programs like Quicken - by default they are disabled for security reasons.  I know few of mine do have this requirement that I had to enable at some point in the past.  Worth the investigation.  Good luck.
    - Q Win Deluxe user since 2010, US Subs R32.12
    - I don't use Sync, Cloud, Mobile, Web, Bill Pay/Mgr, Tax
    - Techie, Win10 Pro x64 21H1
  • MintUserNew
    MintUserNew Member ✭✭
    Thank you for your help on this.

    I found that setting on the Bank of America website for 3rd party settings, but nothing was listed there. The text indicated that one must add through whatever App or website one is using.

    Note, these problems are with my wife’s two accounts. I also have an Alaska Airlines credit card through Bank of America, and I have no problems downloading through Quicken. I have checked all the security settings, and they are identical. It is through Express Web Connect. I never get a request for 2 factor authentication for my account. Yet in Quicken, when her account was connected, it always asked for 2 factor authentication. And today, it won’t even find the account after I enter in the 2 factor key, claiming BofA – All other States is temporarily unavailable.
  • BK
    BK Member ✭✭✭✭
    On your first paragraph: One of my accounts did a similar thing, where I tried to add it to Quicken with login error, but then I had five minutes to go to the website's security center where a prompt magically appeared for me to verify.  If I missed the 5 min window, there was nothing there and I'd have to try again. I learned about that after an online search or I would've never discovered that solution.
    Your second paragraph is the inconsistency that many users have reported here - where some Quicken users never get prompted for BofA's 2FA and everything works fine, while others always get prompted.  My theory on this: BofA is so large with so many servers on various different old & new platforms, that each one of us customers "live" on a different set of their servers (and also State dependent), leading to the inconsistencies.
    I think your situation calls for a support call with Quicken and/or BofA, hoping you get a knowledgeable person on the other end - if not hang up and try again.
    - Q Win Deluxe user since 2010, US Subs R32.12
    - I don't use Sync, Cloud, Mobile, Web, Bill Pay/Mgr, Tax
    - Techie, Win10 Pro x64 21H1
  • MintUserNew
    MintUserNew Member ✭✭
    So I did try being on the BofA website as I added the account, in the Security Center, but I did not see any prompts or anything.

    I can try to reach support at BofA but then I have to have wife around because it is her account. We'll see as reaching customer service is never easy.
  • MintUserNew
    MintUserNew Member ✭✭
    I finally was able to connect my Bank of America credit cards to Quicken with Direct Connect, a month after posting this. I didn't call anyone. I just gave up, and decided I'd Download the transactions from the BoA website as a QFX file. I downloaded the first credit card, it was fine. Then when I downloaded the second credit card, it offered Direct Connect. Skeptical, I said yes. I entered in the username and password. I had to do the 2 factor authentication to my phone twice. Then I saw it found the accounts and had linked them correctly. I was excited. The one more 2 factor authentication, and it said it did it. Hopefully this will work out.
Sign In or Register to comment.