Suntrust setup screen credential requirements in error

This has come up previously with closed discussions and I do not see fixed. When setting up Suntrust, Quicken shows a screen stating that your password must be changed. But the credential requirements presented by Quicken and those for Suntrust do not align. I went through this with support today but posting for others to be aware of. In my case I had to delete the online account and add it back because it quit working. If you use the Advanced option it will bypass the need to change the password. Actual screen shots are attached. Running R35.3. As a second point, when trying to use a special character on the Quicken screen invalidates the entry. Only characters and numbers worked but of course Suntrust rejected.

Comments

  • Quicken Francisco
    Quicken Francisco Alumni ✭✭✭✭
    Hello @Bione

    Thank you for reaching out to the Community about your discovery. That is interesting that you're still able to connect to Suntrust still. I believe a good portion of users have been experiencing issues since the merge to Truist was announced.  In any case, if I do find anyone in need of help I'll be sure to refer them to your post. Thank you for sharing!

    Thanks,
    Quicken Francisco
  • I haven't been able to connect via web connect to suntrust for at least 2 weeks, I'm going to have to either change software or banks it appears. The password issue is apparently part of the problem, suntrust wants a minimum of 8 characters including at least one special character and Quicken says Suntrust won't take passwords with more than 8 characters and special characters aren't allowed.
  • Bione
    Bione Member ✭✭
    I had to delete the accounts first when it stopped working. Setting it up again I used the Advanced Option and selected Web Connect. It did not ask me to reset my password.