Fix fuzzy UI and register text

On my laptop, my display settings are set to 125% size by default for the most comfortable use. I just tonight put two and two together and found that it was indeed this setting that was causing the fuzziness in Quicken when using it on my laptop. This is present (or most notable) anywhere in the interface where there's type. Would it be possible to have the text stay sharp like in other Windows programs like web browsers? It would vastly improve readability. Thank you very much!

Comments

  • Rocket J Squirrel
    Rocket J Squirrel SuperUser ✭✭✭✭✭
    1. Navigate to C:\Program Files (x86)\Quicken\
    2. Right-click qw.exe and choose Properties
    3. On the Compatibility tab, click Change High DPI Settings
    4. On the resulting dialog, Override high DPI scaling behavior, scaling performed by application.
    5. OK out of the dialogs.
    This is not peculiar to Quicken. Other older apps exhibit the same behavior and benefit from the same fix.

    Quicken user since version 2 for DOS, now using QWin Premier Subscription on Win10 Pro.
  • Craig Vorwald
    Craig Vorwald Member ✭✭✭
    Just found this post because I just upgraded to a new laptop with Windows 11.  Thought this post would solve my issue with fuzzy scaled fonts in Quicken.  Not an issue in other programs.  Anyway, qw.exe does not have a compatibility tab under Windows 11, so now I am left trying to figure out a suitable solution.  Help!!  User since 1995.
    Quicken user since 1995...
  • markus1957
    markus1957 SuperUser, Windows Beta Beta
    I'm using Win 11 but find I do not need the Compatibility tab feature as resolution is clear on both a desktop and surface tablet.  In any case, the tab does still exist when following the directions given by @Rocket J Squirrel above.
  • Craig Vorwald
    Craig Vorwald Member ✭✭✭
    Hummm... I just checked again, and on a clean install of Windows 11 Home, when I navigate to qw.exe=> properties I don't see a compatibility tab for qw.exe.  I checked other files of type "application" in the same folder and DO see a compatibility tab for the applications QuickenHomeInventory and billMind but it is missing on QuickenPatch as well.  Yes, I rebooted after installing Quicken.

    On my Windows 10 Professional system (monitor is 1920x1080 resolution), I do have a compatibility tab for qw.exe and all the other programs of type "Application".

    I did experiment with Windows Display settings.  The recommended settings for my system (per windows)  is 250% upscale (3.5K OLED display... 3456x2160 resolution).  If I drop it to 200%, everything gets significantly smaller, but Quicken is more readable.  Unfortunately, it also means I need better glasses.

    Again, I don't have any issues with any other applications except Quicken.  The font handling/rendering falls apart at higher scaling.
    Quicken user since 1995...
  • markus1957
    markus1957 SuperUser, Windows Beta Beta
    You might try applying the Mondo patch.  FWIW, I'm using an admin account in Win 11.
  • almatav
    almatav Member ✭✭
    I've always found that setting it to application-controlled makes for a much, much worse UX. The system-level components like the window frame and title bar, min/max/restore/close buttons, or just about any kind of form fields become so small as to be illegible, and it just doesn't balance out the crisper text. I think that this is really one of those things where Quicken needs to prioritize updating its application platform to allow for assets that work well on on screens and operating systems that were made after the GWB administration.
  • Brian112
    Brian112 Member ✭✭
    Compatibility tab not found.
  • Rocket J Squirrel
    Rocket J Squirrel SuperUser ✭✭✭✭✭
    Brian112 said:
    Compatibility tab not found.
    Your image shows the containing folder. You want to go into that folder and locate the file qw.exe and open its properties.
    Quicken user since version 2 for DOS, now using QWin Premier Subscription on Win10 Pro.
  • ajuliansr
    ajuliansr Member ✭✭
    scaling doesnt help much. here is my register: I cant read the dates, even with a magnifying glass. Pitiful
  • Laptop Elf
    Laptop Elf Member
    If you have problems finding the compatibility tab for qw.exe properties, and you are using Windows 11 try this: right click on qw.exe, then left click on Show More Options then left click on Properties.
  • Mr. Wizard 90
    Mr. Wizard 90 Member
    Solved for my Windows 11 home, 1920 x 1080 resolution. Navigate as identified earlier in this thread to QW.exe properties-> compatibility tab. Under Compatibility Mode, check the box "Run this program in compatibility more for" and then select "Windows 8" in the dropdown below.
This discussion has been closed.