Date display problem with Windows 11

Go into your date format settings and make sure the short date shows as mm-dd-yy. This should resolve your issue.


  • Patrick Barbary
    These are Windows settings BTW, not Quicken settings.
  • UKR
    UKR SuperUser ✭✭✭✭✭
    May I ask why you are reporting this recommendation?
    Is your computer set to a Region other than "English (United States)"?
    IMHO, the Windows Control Panel / Region setting for Short Date should be M/d/yyyy or MM/dd/yyyy because you want to be able to see that the date correctly reflects a year in 20xx or 19xx. There were a few occurrences of improperly imported transactions resulting in dates with years of xx or 00xx and they are impossible to spot with a 2-digit year setting, M/d/yy.
    With a Short Date set as above, date entry into transactions is simplified. You can type dates using a shorthand notation as, e.g., 1201 or 120121 (= Dec 01, 2021) without having to type the slashes. Just remember to type 2 digits each for month, day and year. Quicken will do the rest.
This discussion has been closed.