Getting 2 tags on some transactions

ccsjoe
ccsjoe Member ✭✭
I am getting 2 tags assigned to one entry when I am only needing and keying one. They show up when I run reports. I have Personal and CCS-Business to distinguish the 2 types of transactions. Been doing it this way since the 90's when I first started using quicken. I try to fix the transactions but they resort back to Personal:CCS-Business on reports. Is this a bug and if so can it be fixed?

Answers

  • Frankx
    Frankx SuperUser ✭✭✭✭✭
    edited December 2021
    Hi @ccsjoe,

    You indicated that you are seeing the combined 2 tags on reports.  Can you tell me whether you are also seeing "Personal:CCS-Business" in your registers?  In other words is this both a reporting issue and a transactional issue or just a reporting issue?

    Frankx

                            Quicken Home, Business & Rental Property - Windows 10-Home Version

                                             - - - - Quicken User since 1984 - - - 
      -  If you find this reply helpful, please click "Helpful" (below), so others will know! Thank you.  -

  • ccsjoe
    ccsjoe Member ✭✭
    It shows in the register also. If I try to change it it looks ok on the change screen but when I click save it reverts back to the Combination tag. So there is no way to fix it without deleting the transaction and keying it again. I run a monthly sales report and this is happening for the past 3 or 4 months.
  • Frankx
    Frankx SuperUser ✭✭✭✭✭
    HI again @ccsjoe

    I believe that somewhere along the line, you may have inadvertently added that combined tag to your "Tag List" and for some reason it seems to reverting to that.  You should be able to delete it if you open up your Tag List.

    Go to "Tools" > "Tag List".  Then locate and "click on" the combined tag. Then hit the "Delete" button.

    Let me know how that goes.

    Frankx

                            Quicken Home, Business & Rental Property - Windows 10-Home Version

                                             - - - - Quicken User since 1984 - - - 
      -  If you find this reply helpful, please click "Helpful" (below), so others will know! Thank you.  -

  • ccsjoe
    ccsjoe Member ✭✭
    Already checked that there is no tag for Personal;CCS-BUSINESS. I fell like it is a bug because I should be able to change it on the transaction but it is reversing back to this combined tag. I have been using this program since the 90's and my tags have never changed in 20+ years.
  • q_lurker
    q_lurker SuperUser ✭✭✭✭✭
    How about trying to delete the tag completely on the transaction?  Save the transaction.  Then Add the correct single tag back to it,  

    Also, a validate and repair process might help (no promise there).
  • ccsjoe
    ccsjoe Member ✭✭
    when I do that if comes back on its own. I can delete the transaction and add it again and it appears to work. The question is how is it happening in the first place. Only noticed it because I run a monthly sales report by tag for my busincess CCS and I get personal and business showing and when I looked at the transactions they were showing combined with no way to remove them without re-entering then and deleting the bad one. This has to be some kind of new bug in an update I applied.
  • Frankx
    Frankx SuperUser ✭✭✭✭✭
    Hi again @ccsjoe

    Can you take a Snip of your "Tag List" just so we can see what that looks like.  Make sure the "All Tags" tab is selected - like this:


    You can just drag & Drop it into the message window.

    Frankx

                            Quicken Home, Business & Rental Property - Windows 10-Home Version

                                             - - - - Quicken User since 1984 - - - 
      -  If you find this reply helpful, please click "Helpful" (below), so others will know! Thank you.  -

  • ccsjoe
    ccsjoe Member ✭✭
    Here us a screen shot of my tags. They have not changed since I started using quicken in the mid 90's
    Also one more note is that is appears to only happen on Split transactions so far and mostly for deposits.

    Most of my CCS-Business transactions are spits for my business deposits.
  • Frankx
    Frankx SuperUser ✭✭✭✭✭
    So, I am reaching for straws here...

    Take a look at your "Memorized Payee" list (which can include deposits).  You should focus on the "Tag" column as you page down.  If you find any entries that have that rogue tag - delete them.

    If that doesn't help/work, I suggest that you make a good backup file and then try the Validate file and potentially the Super Validate file processes.  Here's a LINK to those instructions.

    Let us know how things go.

    Frankx


                            Quicken Home, Business & Rental Property - Windows 10-Home Version

                                             - - - - Quicken User since 1984 - - - 
      -  If you find this reply helpful, please click "Helpful" (below), so others will know! Thank you.  -

  • volvogirl
    volvogirl SuperUser ✭✭✭✭✭
    What account are you entering the deposit?   Are you splitting one check or is it several checks?   Maybe it would help to first enter each payment received into a intermediate holding account (called Undeposited Checks) individually.    Then you can add more info for each one.   Then when you make the deposit it is for a single amount and is a Transfer to the Undeposited Checks account.  That way when you download your bank transactions the deposit will match. Or you should use the holding account if you receive payments in one year (like in Dec) but don't make the deposit until the next year (like Jan.).


    You don't run to the bank each time you get a check.  So you need a holding account so you can show the income when you received it.  Then you wait until you get a bunch of checks to go to the bank.



  • ccsjoe
    ccsjoe Member ✭✭
    Don't see any. I also did a search for that combined tag and at this time did not find any. Will see what happens at the end of the month when I run the report again.
  • CdnAb
    CdnAb Member
    I am seeing the same behavior. I go in and fix the tag and save it but my reports are still showing the dual tags. It just started happening and was only on a couple of transactions, so I deleted those and re-entered them. I see no combined tags in my tags list.

    Fixing it in the original transaction did not fix reports. I could change it in the register to show the correct tag not the dual tag, but reports were still showing the dual.

    For instance:
    Ran a report and I see:
    Tag1:Tag2 - even though I only entered Tag2 was in the register.
    - double click on transaction in report would bring me to it and I'd correct it.
    - I'd fix the transaction so it said Tag2 only. But reports wouldn't update
    - Tag list doesn't have any Tag1:Tag2 lines

    What I did notice is that this happened only on spilt transactions and Tag1 was on a line 2 in the split and Tag2 was supposed to be on Line 1 of the split. No amount of tweaking seemed to fix it. The only fix was to delete and re-enter the transaction.
This discussion has been closed.