Quicken R38.30 Update Changed all my Schwab accounts to Simple Investing

I recently updated to Quicken R38.30. After the update, the first time I did a One-Step Update, all my Schwab brokerage accounts were changed to Simple Investing. I checked the preferences and found that the preference at Preferences > Investment transactions > Enable Simple Investing (positions-only) was checked. It was not checked before upgrading to R38.30. I unchecked the preference and manually fixed up the balance adjustment transactions created by simple investing and have now got everything back the way it should be. However, this should not be happening. This has happened to me at least two other times when upgrading, although it's been awhile and I can't now remember what release versions were involved. Anyway, it's irritating.