How to fix inability to link account to financial institution?

The problem I discussed on February 9 ("Silent download transaction error on some accounts from Affinity Plus FCU") which suddenly cleared up has returned. IT's behaving just like described in that post and repeated here except in the meantime I upgraded my Deluxe subscription to Premier. One new wrinkle: After successfully verifying the account for Quick Pay I tried to Verify for Check Pay and that failed with error "Server did not respond to verification request".

I tried creating a new test file using the method described by Quicken Anja. Just like before, the checking account appeared fine with correct balance in it. But returning to my real file I still see an old balance and silent refusal to download transactions.

<<<Starting Sunday morning, Quicken Deluxe R38.29 on Windows 10 fails to download transactions from my checking account at Affinity Plus Federal Credit Union in Minnesota. I have 5 accounts there all using Express Web Connect and 4 of them download transactions fine. The fifth, my checking account, shows no errors but silently refuses to download transactions I know have been there several days. (I can see them on the Credit Union web interface.)
I've tried to use Reset Account multiple times and it behaves differently. Sometimes it simply doesn't see the checking account and tells me I should remove it from One Step Update. Other times it sees the checking account and offers the "Link to Existing Account" option. When I do that, it appears to work and reports that "7943 transactions downloaded". But when it is all done, the new transactions are not there to be seen. And if I try "Reset Account" again, the Checking Account is missing once more.
I'm in a Groundhog Day scenario.>>>
This discussion has been closed.