Quicken Deluxe 2021, R37.66, Build Number

DJPJ Member ✭✭
A couple of months ago, I clicked "UPDATE" and the resulting update caused a massive issue where I could not open my data file and there were completely missing transactions. It intimidated me. I completely uninstalled Quicken Deluxe and reinstalled it and it then worked as a result of that deletion and updated download. Today, when I opened up the program, a HUGE WINDOW (covering the entire program pop-up windows) advised me to click on a link and a "Mondo Patch" page was loaded in my browser. I have questions:
1. Has anyone else had such issues with updates to Deluxe?
2. Has anyone else simply tried to REMOVE the program and re-load it?
3. Is the MONDO PATCH working? If not, what are your issues?

I can no longer trust the Quicken Update functionality because that WORD, function, is missing from the experience. I would welcome any comments and suggestions from users or from Tech support. In order for me to trust auto-updates, the Developers need to get this fixed. I am a user dating back to the DOS days!


  • DJPJ
    DJPJ Member ✭✭
    I wanted to add that my subject header has my current build showing. I do not trust Quicken to auto-update, so I am preventing updates using Windows UAC.
This discussion has been closed.