Quicken Mac Won't Launch (macOS 12.2.1 Intel)

Platz Member
After a few years off from using Quicken, I decided to try it again. First run was fine but the application beach balled while I was setting up accounts. I force quit the app and now it beach balls every time I try to launch.

Things I've tried:
1. Create a new user account and launch Quicken - same behavior
2. Delete ~\Library\Preferences\com.quicken.Quicken.plist - allows the app to launch, but all settings are lost. App won't launch again after quitting.
3. Made sure the file wasn't syncing to iCloud
4. Disabled content blockers, iCloud Private Relay, and any other service that might impact networking - no change
4. Reinstall Quicken - no change

I'm running version 6.6 of Quicken Mac.

Needless to say, this is a terrible first run experience. I'm not sure why I'm keeping up with this, since I've wasted hours on this, but I am.

I chatted with support twice. One time was on Sunday and we couldn't find the root cause. He asked me to try again Monday if I couldn't find the issue, since there would be more support during the week. I tried again today and did most of the same things and the support tech just told me he didn't know and to talk to an IT professional. Well, I'm an IT professional. I can't for the life of me figure out what's going on here and why it seems support doesn't know about this issue, since it's in the forums.

I'm trying the "beach ball and wait" approach that I've seen mentioned here. I hope that fixes the issue, but it leaves me with a sour taste in my mouth. I'm not feeling confident this won't happen again and that any work I put into entering my finances won't all be lost.


  • Platz
    Platz Member
    I let the process run overnight and when I woke up this morning, I was presented with a dialog that said "Quicken needs to perform a one-time update on your Quicken files. This may take several minutes; please be patient."

    I find this very odd for a brand new installation with a brand new quicken file, but letting that process run has allowed my file to open without issue since.

    I don't know if Quicken Support monitors these forums, but if they do, you should look into the first run process and try to understand why the process beach balls on second open trying to update the Quicken database. Usually, when an application beach balls without UI (or even with), the assumption is that you've hit some sort of roadblock and it will be overcome fairly quickly. For Quicken to beachball without CPU or disk usage and without showing UI led me to believe that something was being blocked or otherwise not loaded. Same with your support team. Those are hours of my life I won't get back.
  • RickO
    RickO SuperUser, Mac Beta Beta
    Glad you got it working and I empathize with the pain. Quicken Support does not monitor these forums. Two things you might do if you have the bandwidth: (1) click Quicken menu Help > Report a Problem and describe what happened. You could just cut and past your two posts from here. Including the log files may help. (2) Call back support and get them to note the resolution in your case file and ask them to pass along to the dev team.

    You did a lot to troubleshoot. One other hidden trick you can use in such situations (just for future reference) is to hold down the Shift key while launching Quicken. This will bypass opening the last used file and give you the start from Let's Get Started dialog to verify the problem is with the data file and not something more general.
    Quicken Mac Subscription; Quicken Mac user since the early 90s
This discussion has been closed.