Quicken Premier for Mac 6.6.0 running slow

4pickering
4pickering Member ✭✭
I searched for any possible solutions and only found a reference to "Quicken Deluxe for Mac 6.3.3 running slow". I'd estimate that I've been having the same problems since late last fall. Of course, I too tried all the obvious solutions - shut down all other programs running, rebooted several times, etc. I have an "old" MBP 13" mid-2012 2.9G i7 2 core running Catalina 10.15.7 (seems that's the end of the line OS wise), but frankly I've made upgrades to it (one of the last to allow such upgrades - SSD, 16 GB ram). I routinely get the beachball of death, such that I walk away for an extended period. Is it possible that the new binaries are overtly optimized for M1 at Intel-based Macs' expense?

Any ideas on how to speed performance? My laptop works well for me otherwise. I'm not photo editing or doing compiling apps.

Comments

  • 4pickering
    4pickering Member ✭✭
    One additional item - not sure if this is impactful...it started happening last week, but it seems now, after a reboot, my data file is "out of sync" with Quicken Cloud. I've "resynced" several times, but I need to do it again if I reboot. I don't use mobile - can I turn this off?
  • RickO
    RickO SuperUser, Mac Beta Beta
    edited March 4
    Yes, you can turn off Sync in Preferences > Mobile, Web & Alerts. It is known to cause data problems. If you're not using mobile, you definitely should turn it off.

    I doubt that's going to fix the slowness though. Can you identify a Quicken task that causes the hang, then create a new data file and test that task in a mostly empty file?

    Other things you may not have tried: Copy your file into a new user account and try to run there to see if your Mac user account has something causing this. Startup in safe mode and see if it still hangs.
    Quicken Mac Subscription; Quicken Mac user since the early 90s
  • 4pickering
    4pickering Member ✭✭
    Will do and update you later on this! Thank you!!
  • 4pickering
    4pickering Member ✭✭
    Performance appears to be reasonable since turning off sync. Thank you for the tip!
This discussion has been closed.