How do I change the decimal preferences? (Q Mac)

thedonat
thedonat Member
My banks are US, I'm US, My computer is US.
I'm now in Europe for the moment and all of a sudden $9.99 turned into $9,99

I need period decimals not comma.
Tagged:

Best Answer

  • RickO
    RickO SuperUser, Mac Beta Beta
    Answer ✓
    Open macOS System Preferences. Click on Language & Region. Change the Region back to United States. Click on Advanced and make sure Grouping is a comma, Decimal is a period and Currency is US Dollar.

    Not sure how this got changed. Perhaps macOS automatically changes it based on location services reporting of the computer's location. If so, that's a new one on me. There is a setting in Security & Privacy > Location Services > System Services > Details > Time Zone & System Customization. Having this enabled may be what allowed the Region to be changed atomically. You could turn it off, but you'd lose automatic time zone setting.
    Quicken Mac Subscription; Quicken Mac user since the early 90s

Answers

  • RickO
    RickO SuperUser, Mac Beta Beta
    Answer ✓
    Open macOS System Preferences. Click on Language & Region. Change the Region back to United States. Click on Advanced and make sure Grouping is a comma, Decimal is a period and Currency is US Dollar.

    Not sure how this got changed. Perhaps macOS automatically changes it based on location services reporting of the computer's location. If so, that's a new one on me. There is a setting in Security & Privacy > Location Services > System Services > Details > Time Zone & System Customization. Having this enabled may be what allowed the Region to be changed atomically. You could turn it off, but you'd lose automatic time zone setting.
    Quicken Mac Subscription; Quicken Mac user since the early 90s
  • thedonat
    thedonat Member
    oh brother, no wonder I couldn't find anything on quicken. thank you, that did it!!
This discussion has been closed.