Mac Critical Update Required. Quicken 2016

kab60
kab60 Member
Keep getting this message and when checked I am running the latest version. Says "You're up to date!" If so why will this message not go away?

Answers

  • RickO
    RickO SuperUser, Mac Beta Beta
    edited April 10
    It is asking you to update to the current subscription version of QMac. If you haven't lost them already, you will not have access to any kind of online functionality without updating.

    The message is a bit strange since it's warning you about losing connected service which you should have already lost in QM2016.

    Quicken Mac Subscription; Quicken Mac user since the early 90s
This discussion has been closed.