Historical prices and account values are lost after a few recent updates.

serg Member ✭✭
edited July 2022 in Investing (Windows)

Not all, but some positions are no longer showing history prices and values... I have positions since 2013 which used to work just fine, but now I can only see the history price/market value in Security Detail View starting of end of March 2022.

Not all are impacted, but these are: SSQA3024 MF, DSV TSXV, EMX TSXV.

And I feel it also impacts reporting and Net Worth presentation.


  • Are you using Quicken Canada?  These are Canadian MFs?  If they are, in the "Edit Security Details", make sure BOTH Type and Exchange are "Mutual Fund".  Go to Tools->Security List, and right click anywhere on the security row, and choose "Edit" to get to the "Edit Security Detail".
  • [Deleted User]
    edited June 2022
    Jf the Type and Exchange set up are ok, and prices are being downloaded currently, you can download historical prices to get back the missing prices for the prior 5 years.  Go to your security list and left click on the fund name.  In the pop-up box, click on "More" and then click on "Download historical prices".
  • UKR
    UKR SuperUser ✭✭✭✭✭

    If you suspect that a damaged Quotes Price History causes problems ...
    - Click File / Validate and Repair.
    - Click "Validate File" and "Rebuild investing lots"
    - Also select "Correct investing price history" function "Delete" or "Repair and Rebuild". 
    - Click OK. Let it run.

  • [Deleted User]
    edited June 2022
    @serg, @ukr has a very good idea.  Not sure how your prices went missing, but it could be file corruption.  After you follow the steps in his post, I would suggest you check price history and then download price history again, if you want.  Also anytime you do a major operation on your data file, please make a backup first.
  • serg
    serg Member ✭✭
    thanks everybody for your help/hints

    I had a chance to backup the file and try different steps to isolate the step which will actually correct this issue:

    "Rebuild investment lots" when ran stand alone fixes the problem.

    "Validate File" - does nothing to the original problem but it actually damages some old transfer transactions which are perfectly valid before I run the validation. It removes 'transfer account' from one account but keeps it on the other.

    Transfer between account-1 and account-2,
    Everything is okay with this transfer, 'go to matching transfer' works just fine from either account
    Run 'Validate File'
    Error reported and account-1 still has the transaction in the register but no account-2 is populated, while account -2 register shows transfer transaction with account-1 populated but 'go to matching transfer' results in an error telling to matching transaction exist.
  • carolequirk
    carolequirk Member
    Thanks VM. CDN user here with the same problem. This suggestion fixed it.
This discussion has been closed.