Disabling of auto-categorization is not working again? Help!

dental_floss
dental_floss Member ✭✭
At one point, I opened a support ticket to get auto-categorization of downloaded transactions turned off (like Quicken behaved on Windows for many, many years). The kind support folks were able to show me how to configure the version of Quicken I was using to stop autocategorizing (basically uncheck "automatically improve the quality of downloaded payee names and categories"). This worked for some period of time, as long as I did not Sync to the cloud. Once I synced to the cloud, then transactions would get auto-categorized once again. So, I avoided syncing to cloud and all was good.

Now I notice that downloaded transactions are getting auto-categorized again and I don't know how to stop this. Super frustrating. Downloaded transactions should have the category 'Uncategorized' or the category should be blank.

Please tell me how to automatically download my financial institution's raw transaction data, without Quicken automatically messing up the categories.

Comments

  • Quicken Jared
    Quicken Jared Moderator mod
    At one point, I opened a support ticket to get auto-categorization of downloaded transactions turned off (like Quicken behaved on Windows for many, many years). The kind support folks were able to show me how to configure the version of Quicken I was using to stop autocategorizing (basically uncheck "automatically improve the quality of downloaded payee names and categories"). This worked for some period of time, as long as I did not Sync to the cloud. Once I synced to the cloud, then transactions would get auto-categorized once again. So, I avoided syncing to cloud and all was good.

    Now I notice that downloaded transactions are getting auto-categorized again and I don't know how to stop this. Super frustrating. Downloaded transactions should have the category 'Uncategorized' or the category should be blank.

    Please tell me how to automatically download my financial institution's raw transaction data, without Quicken automatically messing up the categories.
    Hello @dental_floss,     

    I am sorry to hear about this issue with auto-categorization. Thank you for looking to the Quicken Community for assistance with this issue.

    First, save a backup by going to File > Copy or Backup File... in the upper menu at the top of the screen, then proceed through the steps listed below:

    1. Go to Quicken → Preferences.
    2. Select the Register tab.
    3. Uncheck the Automatically create rule... checkbox to turn off automatically creating a QuickFill rule when editing a transaction.
    Let me know if you are still noticing this issue after these steps have been taken.

    Thank you,

    Quicken Jared 
  • dental_floss
    dental_floss Member ✭✭
    Hi Quicken Jared, Thank you for the response. The setting was already turned off (and has been).
  • Quicken Jared
    Quicken Jared Moderator mod
    Hi Quicken Jared, Thank you for the response. The setting was already turned off (and has been).
    Hello @dental_floss

    Thank you for getting back to me about this. I am sorry that this issue is continuing. 

    If you have the chance, it would help us to troubleshoot the situation if you could save a backup by going to File > Save a Backup... in the upper menu at the top of the screen while Quicken is open and then create a new 'test' data file by following the steps listed below:

    1. Navigate to File
    2. Select New
    3. Select Start from scratch
    4. Click Next
    5. Choose appropriate default categories based on geographic location
    6. Click Next
    7. Choose Don't use Quicken Mobile & Web
    8. Click Next 


    You may then add your non-Charles Schwab affiliated accounts in the newly created data file by choosing your financial institution and entering your credentials as prompted. I am curious whether or not these issues continue in this data file.

    I am eager to hear back about your results. 

    Thank you,

    Quicken Jared 
  • dental_floss
    dental_floss Member ✭✭
    Hi,

    Ok, I took the steps you recommended. Added just one bank and downloaded the transactions.
    They were already categorized. I then brought up Preferences>Connected Services and see that the 'Automatically improve the quality of downloaded ..' option IS already checked.


    Next I tried another new 'test' data set, this time, during the setup, I exited out of the step to add a bank account. I then went to preferences and unchecked the above option. Then I added my bank account and downloaded transactions. This time most of the transactions were 'Uncategorized', but a few were tagged as 'Transfer' or 'Credit Card Payment'.

    So, that tells me it is possible to get the app to leave most transactions as 'Uncategorized' during download (by unchecking the above option), but doesn't tell me why the app is ignoring the setting for my primary data file.

    Note, wherever this debug is going, it must preserve all my personal categorizations over the last many years for my primary data file.

    Thanks
  • Quicken Jared
    Quicken Jared Moderator mod
    Hi,

    Ok, I took the steps you recommended. Added just one bank and downloaded the transactions.
    They were already categorized. I then brought up Preferences>Connected Services and see that the 'Automatically improve the quality of downloaded ..' option IS already checked.


    Next I tried another new 'test' data set, this time, during the setup, I exited out of the step to add a bank account. I then went to preferences and unchecked the above option. Then I added my bank account and downloaded transactions. This time most of the transactions were 'Uncategorized', but a few were tagged as 'Transfer' or 'Credit Card Payment'.

    So, that tells me it is possible to get the app to leave most transactions as 'Uncategorized' during download (by unchecking the above option), but doesn't tell me why the app is ignoring the setting for my primary data file.

    Note, wherever this debug is going, it must preserve all my personal categorizations over the last many years for my primary data file.

    Thanks
    Hello @dental_floss,                

    I am sorry to hear that this issue remains ongoing. Thank you for remaining in communications with the Quicken Community about what is happening.

    When did this issue begin? We recommend saving backups frequently by going to File > Save a Backup... in the upper menu at the top of the screen while Quicken is open. Provided that this has been done regularly, you should be able to restore from a recent backup saved prior to when this issue emerged by going to File > Restore a Backup... in the same menu mentioned previously. I want to know if you notice that this problem continues in the restored backup.

    I look forward to hearing back from you about your results. 

    Thank you,

    Quicken Jared 
  • dental_floss
    dental_floss Member ✭✭
    Hi,

    This has happened on-and-off for at least the last several years. This never happened for me when I was using the Windows version of Quicken. I believe at one point, Quicken support told me that there was an issue with the application in that even though the user set the option to 'off', the application would ignore that or think that it was still set to 'on'. Likely this is related to the auto-migration that happens to the datasets when the Quicken app has been updated to newer versions....and the option is getting 'lost' during that migration. Since the app is frequently updated, it would be hard to know when this started happening again exactly.

    I do save regular backups, but unfortunately, if you think about it, your latest suggestion is not feasible. I would have to re-open 10s of backups and try each one individually. Since I'm a paying customer, I shouldn't have to debug the software... that should be the left to the paid employees.

    If the software is well written, then there should be a way to dump out a debug log of the current user settings that are being honored during transaction download (and directly thereafter), including the setting for auto-categorization.
This discussion has been closed.