Security found in search fails to update details

AMP61 Member ✭✭
I have been attempting to get 'Middlefield Sustainable Global Div ETF' to populate the details into Quicken (Version R40.28).
I go into Security Details, (TSX lists the ETF as MDIV), I use the Security Symbol Lookup for MDIV but that fails, I then searched for 'Middlefield' and found the correct security under the ETFs tab.
TSE:MDIV - Middlefield Sustainable Global Div ETF - TSX
I select it, set type to Other (I have tried others as well), the Exchange is currently set as 'Toronto', Asset class is 'other' and I have selected 'Download asset class information'.
I have made several attempts and changed the symbol, type and exchange and it consistently fails to update history for this security.
Suggestions welcomed.


  • @amp61 - if you choose "Mutual Fund" as the Type, then the Exchange must be "Mutual Fund" as well.
  • AMP61
    AMP61 Member ✭✭
    Thanks, I did try that and then realized that I could create a type 'ETF'. I then set it to Exchange Toronto and it worked.
  • @amp61 - glad you figured it out.  I think "ETF" should be one of the standard security types.  Lately, there have been a few Canadian users with ETF issues.
This discussion has been closed.