QFX Files not importing - lost Windows file type association

pezlud
pezlud Member ✭✭
This happened earlier this year, where I had to deactivate accounts and then set them up again.

Now, in August 2022, after a Quicken update, the QFX files would not import. I again deactivated the online settings, saved the QFX file, and opened it, linked to existing account. Fine.

But now, the QFX files still DO NOT open. Have to save the file and manually open again. What's going on?

[Removed - Disruptive/Speculation]

Comments

  • Ps56k2
    Ps56k2 SuperUser ✭✭✭✭✭
    I'm confused on the various scenarios....
    What bank are you manually downloading these QFX files ?
    What version ..... Help --> About Quicken
    If you are manually downloading the QFX files - did they used to automatically invoke the Quicken Import -
    and now they do not do this automatically ?
    If you click on the QFX file - does anything happen ?
    If you click on the Quicken menu --> File --> Import --> and point to the QFX file - does that work ?

    QWin Deluxe Subscription - sticking with R47.15 - Win10

  • pezlud
    pezlud Member ✭✭
    Ps56k2

    Various banks, Chase, Citibank, Discover. Yes, I manually download so I can choose dates etc., and don't have to enter passwords into Quicken (don't trust that)

    They used to open automatically when downloading.

    Now, they don't. Have to save the QFX file, then right click on the file, open with Quicken and then it works. Haven't tried the Quicken menu, file, import, QFX yet
    Quicken Premier, version R42.21, Build 27.1.42.21 for Windows 10 (Windows updated last night)
  • Ps56k2
    Ps56k2 SuperUser ✭✭✭✭✭
    edited August 2022
    pezlud said:  ... then right click on the file, open with Quicken and then it works.
    When you see "Open with Quicken" - don't open with Quicken -
    Instead - look at bottom --> click Choose Another App -->
    then find & select Quicken - BUT also look for [ ] Always Use This App ...  and checkmark it [x] for all future times...
    Click OK -

    QWin Deluxe Subscription - sticking with R47.15 - Win10

  • Chris_QPW
    Chris_QPW Member ✭✭✭✭
    edited August 2022
    Are you using Firefox?

    In other threads it has been reported that they have made changes recently that you have to go into the settings and tell it that you want to open the QFX file.  Note that there are two separate operations.  The downloading and the opening of the downloaded file once it is finished downloading.  I don't use Firefox so I can't give you the details on this, but in general you pick the difference by "opening the link" or "downloading the link".  And it sounds like Firefox removed the "open" option unless you change something in the settings to allow it.

    EDIT.  I should add, all of this is outside of Quicken's control.  What Quicken does is register with Windows that I want's to be the default program to open when you open a QFX file.  It is up to the web browser to do that open.  And also the same thing happens if you open the the file in Windows File Explorer if you double click on the QFX file.  If it works in Windows File Explorer then the "registering" part is correct and that only leaves the web browser as the problem.
    Signature:
    This is my website: http://www.quicknperlwiz.com/
  • pezlud
    pezlud Member ✭✭
    Chris_QPW I have the setting done in Firefox. It's set to open QFX with Quicken. This didn't happen until Quicken did a major update recently. Was working fine before that!
  • Chris_QPW
    Chris_QPW Member ✭✭✭✭
    pezlud said:
    Chris_QPW I have the setting done in Firefox. It's set to open QFX with Quicken. This didn't happen until Quicken did a major update recently. Was working fine before that!
    Did you do the test in Windows File Explorer?
    Signature:
    This is my website: http://www.quicknperlwiz.com/
  • pezlud
    pezlud Member ✭✭
    Well, another Update from Quicken and the import of QFX files NOT FIXED!

    https://community.quicken.com/discussion/7905187/ongoing-8-23-22-qfx-web-connect-files-not-importing#latest
  • pezlud
    pezlud Member ✭✭
    I do NOT understand. Quicken opening automatically qfx files went on for years. Then, one update ruined it. Why can't they get it fixed?

    https://community.quicken.com/discussion/comment/20295965#Comment_20295965
  • Ps56k2
    Ps56k2 SuperUser ✭✭✭✭✭
    Chris_QPW said:  for .... @pezlud --->
    Are you using Firefox?

    In other threads it has been reported that they have made changes recently that you have to go into the settings and tell it that you want to open the QFX file.  Note that there are two separate operations.  The downloading and the opening of the downloaded file once it is finished downloading.  I don't use Firefox so I can't give you the details on this, but in general you pick the difference by "opening the link" or "downloading the link".  And it sounds like Firefox removed the "open" option unless you change something in the settings to allow it.

    EDIT.  I should add, all of this is outside of Quicken's control.  What Quicken does is register with Windows that I want's to be the default program to open when you open a QFX file.  It is up to the web browser to do that open.  And also the same thing happens if you open the the file in Windows File Explorer if you double click on the QFX file.  If it works in Windows File Explorer then the "registering" part is correct and that only leaves the web browser as the problem.
    1 - did you click on it from Windows File Explorer - as requested ?
    2 - are you using FF as your browser - as asked  ?

    QWin Deluxe Subscription - sticking with R47.15 - Win10

  • pezlud
    pezlud Member ✭✭
    @Chris_QPW

    I'm using FF. Settings in FF say that default option to QFX is to use Quicken Windows.
    Double clicking in Window's Explorer opens Quicken and then the QFX file.

    The moderator keeps saying this glitch isn't fixed. Why did it happen after a Quicken update?

    If windows explorer works and FF is set to open QFX with Quicken, where is the problem?
  • Chris_QPW
    Chris_QPW Member ✭✭✭✭
    pezlud said:
    @Chris_QPW

    I'm using FF. Settings in FF say that default option to QFX is to use Quicken Windows.
    Double clicking in Window's Explorer opens Quicken and then the QFX file.

    The moderator keeps saying this glitch isn't fixed. Why did it happen after a Quicken update?

    If windows explorer works and FF is set to open QFX with Quicken, where is the problem?
    Now that I know you are using FireFox, see this thread:
    https://community.quicken.com/discussion/comment/20252917
    Signature:
    This is my website: http://www.quicknperlwiz.com/
  • pezlud
    pezlud Member ✭✭
    @Chris_QPW

    I changed the setting in FF from "open with Quicken" to "open with Quicken (default)". Now it seems to work; at least at the 2 places I've tried so far. Wonder why it needed the default setting and not just open with Quicken??????
  • Chris_QPW
    Chris_QPW Member ✭✭✭✭
    pezlud said:
    @Chris_QPW

    I changed the setting in FF from "open with Quicken" to "open with Quicken (default)". Now it seems to work; at least at the 2 places I've tried so far. Wonder why it needed the default setting and not just open with Quicken??????
    I guess they think it make FireFox either more flexible or more secure.  I don't really know the reason.
    Signature:
    This is my website: http://www.quicknperlwiz.com/
This discussion has been closed.