Cannot delete security even after purging all transactions

justmakeitwork Member ✭✭
I have ~10 securities that I can not delete. The delete button is greyed out. I purged the transactions some time ago. When I open the Securities Window and look for transactions or if I run a report there are no transactions found.

I am approaching the security limit so I need to be able to purge these securities soon. Does anyone have any ideas on how to purge these securities?

Thank you


  • Mark1104
    Mark1104 Member ✭✭✭✭
    did you try to validate and repair the file? that could clean up something....
  • justmakeitwork
    justmakeitwork Member ✭✭
    edited November 2022
    Yes, many times. Thank you I should have mentioned that as it is the first step one should do. However, It does not detect any issues with these securities.
  • mshiggins
    mshiggins SuperUser ✭✭✭✭✭
    The security limit is 2000 trackable securities. No one seems to know precisely what makes a security “trackable”. How many securities do you have in your file?

    Quicken user since Q1999. Currently using QW2017.
    Questions? Check out the Quicken Windows FAQ list

  • Mark1104
    Mark1104 Member ✭✭✭✭
    edited November 2022
    @justmakeitwork - did you Super validate?????

  • Interesting you say the maximum is 2000. This is what it states inside the DATA_LOG.txt validation file, "Maximum security reference: 252, number of securities: 238. Analyzing securities."

    My data dates back to 1994 when some of these securities were first purchased. I had purged some transactions around 5 years ago. My qdf data file is around 170MB at the moment.

    And @Mark1104, "Super Validate?????" . I don't see that option! I want a Super Validate button too! Please share if there is one!
  • Mark1104
    Mark1104 Member ✭✭✭✭
    @justmakeitwork - To Super Validate your file, first hold down the CTRL+SHIFT keys, and then choose File menu > File Operations > Validate and Repair

    suggest checking 'rebuild investment lots" also
  • I honestly thought you were joking with the Super Validate option. :)

    I did a super validate and tried rebuilding investment lots. Everything seems fine, however every time I run Validate and Repair it shows the 3 Old Style Buy investment transactions updated. My guess is that they never get updated. The log file states..

    Rebuilt investing lots.
    Analyzing securities.

    Number of old style Buy/Cash/Transfer investment transactions updated: 3/0/0
    No out-of-range security references found.

    My initial motivation for purging data is to get some performance improvements. Quicken seems sluggish at times and stalls when entering categorization data at random times.

    My data file is 170MB (without any attachments). I typically run validate and repair every year if not a few times a year. I know the performance issues do not have anything to do with my computer which is a quad core Xeon processer with 32 GB of ram.

    Any ideas?
  • Does anyone know what this statement from my validation file means?
    "Maximum security reference: 252, number of securities: 238. Analyzing securities."

    Quicken is suppose to hold up to 2000 securities.
  • Mark1104
    Mark1104 Member ✭✭✭✭
    it just means you have 252 securities..... interesting that the difference is 14, which is your issue.  On my file (which is over 20 years old), the two numbers match.  
  • Arctic Hare
    Arctic Hare SuperUser ✭✭✭✭
    FWIW, My data file is 1.2 GB and the two security numbers are different by one in my case:

    All internal consistency checks passed.

    [Tue Nov 08 21:54:24 2022]
    Maximum security reference: 145, number of securities: 144.
    No out-of-range security references found.

    I would say that I have no performance problems with Quicken other than, if I leave it open but minimized for a day, when I bring the Quicken Window back up it takes a couple seconds to refresh the data and become responsive (PC has Ryzen 5 5600X, 32 GB RAM, NVMe O/S drive, and MSI Radeon 6600 Mech 2).
  • 1.2GB is a large file size, do you have a number of attachments in there? I wonder what "No out-of-range security references found." means?
  • Arctic Hare
    Arctic Hare SuperUser ✭✭✭✭
    Answer ✓
    1.2GB is a large file size, do you have a number of attachments in there? I wonder what "No out-of-range security references found." means?
    I do have many attachments as well as many transactions in my Quicken file. A few things to consider: - Quicken tech support, especially the elevated tiers, strongly recommends against running validate as a routine practice. They assert that periodically running Validate poses more risk of doing more harm than good. They also recommend only running SuperValidate if advised to do so by Quicken support; there is a reason why it is a hidden feature. Quicken has never fully disclosed the difference between SuperValidate and Validate, but the available information suggests SuperValidate performs some more aggressive corrections for a very narrow range of issues. SuperValidate can fix a very limited set of issues that aren't fixed by validate, but it poses a greater risk of corrupting your data file such that it can never be recovered. Think of SuperValidate as a last resort option to save a corrupted datafile - restoring a backup is probably a better option in most cases. I'm not necessarily bought into the assertion that running validate periodically is a bad idea, but I'm not going to wade into that debate. I do accept that running validate presents some risk; not running validate also presents some risks. - In conversations that I've had with Quicken support, they've never been concerned with the difference between maximum security reference and number of securities. And "no out of range" security references is normal - whatever it means. - I believe that note in the validation file that reads "maximum security reference" would better read "highest numbered security referenced". It's not a limit; just the biggest number used. I suspect that the difference between that "maximum" and the number in use is the number deleted - or something like that. - It appears that you are a long way from needing to delete securities. Have less than 240 and max is 2,000
This discussion has been closed.