Quicken Mac subscription - Very slow when startup or click on anything

jhyuen
jhyuen Unconfirmed, Member
Been using Quicken for more than 20 years, using everyday to manage my investment. Recent upgrade caused very slow when startup or click on anything

Comments

  • Quicken Jared
    Quicken Jared Moderator mod
    jhyuen said:
    Been using Quicken for more than 20 years, using everyday to manage my investment. Recent upgrade caused very slow when startup or click on anything
    Hello @jhyuen,   

    I am sorry about this issue with slow performance and crashing. Thank you for letting us know about this here on the Quicken Community. 

    Have you tried restarting your computer? Also, you may attempt to uninstall the software by making use of the instructions provided here, then waiting 5 seconds or so and reinstalling it using these instructions.

    I look forward to hearing more from you about this. 

    Thank you,

    Quicken Jared 
  • jacobs
    jacobs SuperUser, Mac Beta Beta
    @jhyuen Click on the red Q logo in the upper right of the screen and select Show In Finder from the dropdown menu. Where is the location of your data file? Is it in a Documents folder within Quicken, within Application Support, within Library, within your home folder? Or somewhere else? 
    Quicken Mac Subscription • Quicken user since 1993
  • Carl E. Belles
    Carl E. Belles Member ✭✭
    For the record, I've been having the same problem the last few days. Seemingly everything I do (particularly editing an entry in any account) gets me the spinning wheel of doom, and takes 5 seconds or so to complete. I've restarted my Mac multiple times, and it doesn't seem to make a difference.

    My Quicken data file is in a subfolder of my "Documents" folder, not within a Quicken subfolder.

    Might try to uninstall and reinstall unless someone has a better idea.

    Quicken Version 6.10.3 (Build 610.46328.100), MacOS Monterey 12.6.1, 2017 iMac Retina 3.8GHz Quad-Core i5, 40GB RAM
  • jacobs
    jacobs SuperUser, Mac Beta Beta
    @“Carl E. Belles” Have you checked to see if you have any open windows behind the main window? An open report can cause the behavior you describe.

    The other potential problem area is if you have macOS set to store your Desktop and Documents folders on iCloud. That also can result in behavior like you’re describing. Check your System Preferences > Apple ID to see if iCloud Drive is on and set to store these folders.
    Quicken Mac Subscription • Quicken user since 1993
  • Carl E. Belles
    Carl E. Belles Member ✭✭
    edited November 25
    No open windows other than the main window. Uninstalled/reinstalled Quicken for Mac yesterday; no change.

    I do have iCloud Drive active (Desktop and Documents folders are kept locally and synched to iCloud), but I've had iCloud active for years, and it's only within the last week or so that Quicken has behaved like this.

    I did uninstall BitDefender, as it was using a lot of CPU time, but this made no difference either.
  • jacobs
    jacobs SuperUser, Mac Beta Beta
    I do have iCloud Drive active (Desktop and Documents folders are kept locally and synched to iCloud)
    To the best of my knowledge, if you check the Desktop & Documents folders checkbox in iCloud Drive, you are not storing those folders locally; you are storing them on iCloud even though your Mac represents them as if they are on your local Mac. And doing so is known to sometimes cause issues with Quicken Mac. 

    So as a simple test, move your Quicken file to another location. I'd suggest creating a Quicken folder inside your Home folder. See if this makes a difference. 
    Quicken Mac Subscription • Quicken user since 1993
  • Carl E. Belles
    Carl E. Belles Member ✭✭
    Moved Quicken file to a folder *not* synching with iCloud, and restarted Mac. No change.

    As far as I can tell, Quicken is the only piece of software behaving this way. Getting frustrating.
  • Carl E. Belles
    Carl E. Belles Member ✭✭
    Answer ✓
    Well. That's embarrassing.

    There was, indeed, a report running in the background. Quite a large one. I have no idea how I missed it, but I closed it and all is well with the world.

    I might need to start making more coffee in the morning.
  • jacobs
    jacobs SuperUser, Mac Beta Beta
    I’m glad you found it and the problem is resolved! And thanks for posting back here to let anyone reading this thread know the issue was a report which was open in the background. This is the most common culprit when Quicken is slow at entering transactions, and the user interface unfortunately makes it too easy to miss.
    Quicken Mac Subscription • Quicken user since 1993