Downloading transactions changes dates in the register (Q Mac)

jhs0807
jhs0807 Member ✭✭
I am using Quicken 6.10.3. When I download transactions, some dates are changing from my manually entered dates to the posted dates, despite having unchecked the preference "Use posted date for matched transactions (instead of the date you enter manually)." This preference was obeyed several minor versions ago, but it seems to have broken in the past few months. Anyone else having this problem?

Comments

  • lhossus
    lhossus SuperUser ✭✭✭✭✭
    The easiest thing to try to fix this:

    Go to the preference setting and check the box to enable the preference. Then, close out the preference window, and quit Quicken.

    Now, relaunch Quicken, go to the preference setting and uncheck the box to disable the preference. Close the preference window.

    Now cross your fingers when you do your next download of transactions.
    Quicken Mac Subscription • macOS Monterey 12.6 on MacBook Pro 13" M1
  • jacobs
    jacobs SuperUser, Mac Beta Beta
    @jhs0807 I've seen a number of reports of switched/messed up Quicken preference settings after people updated their macOS to Ventura; I don't know if you did so recently? As advised above, changing the preference setting, saving it by quitting, then re-launching and changing it back and quitting again has seemed to fix these issues for people who reported on it.
    Quicken Mac Subscription • Quicken user since 1993
  • I am having this same issue. Really need to get this fixed. It may have started when I upgraded to Ventura
  • This did not fix my issue. Anyone find another fix?
  • jhs0807
    jhs0807 Member ✭✭
    @lhossus, thanks for the suggestion, but it did not fix my issue. It took me a few days to see whether or not transactions would follow the manually entered date, and at least one did not.

    @jacobs, maybe this problem coincided with an Monterey upgrade to 12.5, but I haven't yet upgraded to Ventura.
  • Paul Read
    Paul Read Member ✭✭
    I've been seeing the same problem. I've completed the fix suggested above. Now, wait and see.
  • Kathy Muench
    Kathy Muench Member ✭✭✭
    I posted the same issue in another thread, but forgot that I had also updated to Ventura recently, so maybe that's the problem for me. I thought it was because I only recently turned on Auto_reconcile for a few accounts (I have been manually reconciling since 1994 lol! and thought I'd give it a try). I am going to wait a few more days before either turning off Auto_reconcile or maybe trying the fix suggested above. I updated to Ventura several days before turning on Auto_reconcile though, and I didn't notice the dates changing until after I had enabled Auto_reconcile.
  • jhs0807
    jhs0807 Member ✭✭
    I find this bug to be random. I pay all my utility bills by check on the last day of each month, and it takes several days for the checks to be received through the mail and then cashed. When downloading the transactions, I have had several of the checks keep my originally entered date and several change to the posted dates.
  • Kathy Muench
    Kathy Muench Member ✭✭✭
    Updated to 6.11.1 - this issue is not fixed. @jhs0807 - yes, very random. @jacobs - the fix has not worked for me (I did it before and after the update to 6.11.1). Neither did turning off auto-reconcile. The update was released about the same time that the alert said it had been resolved, so maybe the resolution will actually go into the next update?
  • John Waers
    John Waers Member ✭✭
    After an extended chat session with Quicken support, it seems that the problem (at least as I’ve observed) lies with accounts that were recently migrated from Direct Connect to Quicken Connect. Accounts updated with Web Connect using a downloaded QFX file are not affected because the transaction date is preserved in the file. Summary of my chat session: “… our development team is planning to deploy a patch/fix for that problem in this current version 6.11 …”
  • jhs0807
    jhs0807 Member ✭✭
    I just updated to 6.11.3 and this issue is still not fixed.
  • Kathy Muench
    Kathy Muench Member ✭✭✭
    I turned off sync (to Mobile and Web) when I had to restore from a previous backup on Jan 1, and turned off auto-reconcile several days ago.  I updated to 6.11.2 after that and to 6.11.3 today and for me, the issue seems resolved.  Not sure which option did the trick (or whether it may show up again, but I'm not going to turn sync back on until I have to go on a trip without my laptop because I find the mobile and web apps not very useful).