Old OSX Version Compatibility

QuickDillo
QuickDillo Member
edited January 30 in Before you Buy
What version of Quicken will work on both OSX 10.9 and 10.13?
Tagged:

Answers

  • John_in_NC
    John_in_NC SuperUser, Mac Beta Beta
    Available from Quicken? None.

    Older versions available third party? Quicken 2007 Lion Compatible (16.1.x), Quicken Essentials, and 2015.

    No online services would be supported in any fashion, including downloading/importing transaction files from banks. I can't even say how registration might hamper things as Intuit (the previous owner of Quicken) no longer has servers running for those old programs.

    Caveat emptor. 
  • I've been using Quicken Essentials 2010, and it won't run in High Sierra (10.13). Thanks for the suggestions.
  • John_in_NC
    John_in_NC SuperUser, Mac Beta Beta
    I've been using Quicken Essentials 2010, and it won't run in High Sierra (10.13). Thanks for the suggestions.
    My apologies: I had to fire up an old laptop that I keep around for the '05-'07, Essentials questions. I thought it was 10.13. I blew off the cobwebs and see it was running 10.11.
This discussion has been closed.