Account registers opens highlighting random transaction and also problems with transaction entry

Diana Member ✭✭✭
Just recently (since last update), when I open an account, the register arbitrarily highlights some random transaction in the past or the future.  I believe it used to open showing the empty (new) transaction at the bottom of the account register.

As well, entering a new transaction seems to be having pointer problems.  After entering a transaction, the cursor/highlighted next transaction to work on is incorrect.  For example just after I enter a new transaction, the cursor goes to the subsequent transaction (but not to the new empty transaction slot at the bottom of the account register). As part of this, which is even more irritating, it selects the complete date field as though I am replacing the full date value.  If I start to type it comes back and says I need a valid date format.  I'm so used to typing in the day (because i'm usually entering multiple entries in the same month/year in one session) and then tabbing to the next field.  This no longer works.  I have to cancel changes to an existing valid transaction. 

Is there some change in the editing preferences that I am missing?  I didn't think this had changed. 


  • davie
    davie Member
    Same prob. Click date in register on an existing transaction displays a white Hover Box containing a "01 +01 ?-in a box" when clicking on a January (01) date. Have to click elsewhere to remove and try again. Sometimes the Date Grid will appear and sometimes cannot get around the Hover Box. Just started this morning 1/2/2023. Used Quicken yesterday 1/1/2023 without issue. Anyone else having problems?
    I have Windows 11. Tried going to regional settings and converted Windows Date format from 1/1/2023 to 01/01/2023. Actually, this changed the format within Quicken from 1/2/2023 to 01/02/2023 after restarting Quicken. However, the Hover Box continues to be an issue. Thanks!
  • davie
    davie Member
    Follow-up to above "Hover Box" issue appearing when clicking on a date on existing date in register. Apparently, the Windows 11 Date format defaults to "m/d/yyyy". My Quicken account has always been setup to use the Windows Date format and my Windows computers were always setup to be "mm/dd/yyyy" thus, a mismatch between windows/quicken.
    Simply updating Windows 11default to mm/dd/yyyy and closing/opening Quicken did not fix.
    Curious, I closed Quicken and then Shutdown Windows. After restarting windows and launching Quicken the PROBLEM NO LONGER EXISTS. No more Hover Box !!! Hope this helps anyone with similar issue. Happy New Year.
  • Diana
    Diana Member ✭✭✭
    My problems have also gone away.  Thank goodness! 
  • kenr
    kenr Member
    Thanks Davie and Diana; when reconciling transactions with the clr column and click R, then clicking on the Category box the curser jumps back to the date box. Clicking on the same box another click it stays in Category. Entering data after the first click it sends transactions to completely bogus areas fowling up the reconcile. Anyone know how to set up to click once on the Category and have it stay there?
This discussion has been closed.