Average cost setting being ignored

Fidelity automatically selling shares from multiple funds proportionally from IRA account monthly to meet RMD. All funds set to average cost, but setting is being ignored when "Accepting All" downloaded transactions, requiring individual "Accept" with "Lot Identification/Average Cost" dialog box for each sale. Am I missing something? Thanks.

Comments

  • Sharkbait
    Sharkbait Member ✭✭
    Same issue here.
  • Michael Jones
    Michael Jones Member ✭✭
    I consider this a bug. What's the proper way to report it?
  • q_lurker
    q_lurker SuperUser ✭✭✭✭✭
    Under the Edit / Preferences / Downloaded Transactions,
    1) Is automatically add to investment transaction list checked?
    2) What are your Lot assignment settings for this particular account?  

    I suspect 1) is unchecked
    I suspect 2) is Quicken default
    (Those happen to be my settings, not that it matters.)

    So you then get a set of transactions downloaded, including these sales, you click Accept All, and are prompted for what to do on these sales with the options to use average cost or specify lots.  Is that where your issue arises?  You've already identified the average cost should apply and you should not be asked again.