Why is Quicken slow to open up?

Quicken takes 2 to 4 minutes to open up after selecting app. I get a white screen. Once Quicken is open it operates just fine. I believe it started maybe a week ago and maybe after the last update. I have uninstalled and reinstalled Quicken with no change. I contacted Quicken tech and worked the problem with no corrective action. We even opened up an old backup fine with same problem. Tech's answer was to wait until next patch update and see if that fixes the problem. All other programs in my computer open up and operate fine.

Answers

  • stanzoid
    stanzoid Member ✭✭

    I have the same problem. Takes 4 minutes to open, and has done so for a week or so. I was going to reinstall until I read your post. Thanks!

  • Ronferd
    Ronferd Member

    I have the sameissue. I did unistall and re-install. Validated files. Still the same issue. It takes minutes to open the file then works fine .

  • jjamberg
    jjamberg Member ✭✭

    Same issue after updating to the March 2023 release. Takes minutes to open, Windows PC is unsuable during this time (high memory/CPU usage), then operates fine.

  • UKR
    UKR SuperUser ✭✭✭✭✭

    @jjamberg ,

    how much RAM do you have installed on your computer and what Windows version are you running?

    I had a similar situation last year on my "elderly" Windows 8.1 system. A RAM upgrade from 4GB to 8GB solved the observed problem with high RAM usage (up to 96%) and excessive paging/swapping to the C: - drive.

  • dashette
    dashette Member

    I have the same issue with slow load time. It can take over 5 minutes for Quicken to load. While it is doing this, my whole PC is almost unusable as Quicken is taking up all of the resources. Note that I have 16GB of memory, so lack of memory is not the issue. It all started about a week ago.

  • jjamberg
    jjamberg Member ✭✭

    Sorry for delayed response. My computer is pretty new (3yrs. - running Windows 10 with 16GB of RAM and an i7 processor. I also am using an SSD drive as my primary Hard Drive. I don't think my computer is at fault here….this issue only is present at Quicken Startup on the latest version; otherwise the PC runs 100% perfect. Others on this site have also complained of similar issue when running the latest version of Quicken

This discussion has been closed.