Cannot Add New Subcategories -The list in new category box stops part way, doesn't fully populate

gcquick Member ✭✭
I am running Quicken R.48.18 on Windows 10. Tried to add a new subcategory to Travel, but the dropdown subcategory list stops at expense PST . Since T for travel is beyond PST, it is not possible to add it. I ran a validation check and got no errors.

This appears to be the same problem reported in this a prior thread. That thread suggested, as a solution: "Delete any categories with names like "ACCT_###"." This did not work for me. There were no such account names.

But I found a fix, and think we are just saying the same thing in different ways. Essentially, accounts in the list of categories should be listed in the "Type" field as a "Transfer" -- not as "Expense." (My account was named R-HV123, but it could be called anything.

But I noticed that this account was listed in Type field as "Expense." Also, the account, unlike others, was not shown in brackets.

Because it was categorized as an Expense, this blocked the New Category box from loading anything beyond the last valid Expense.

To fix this, the first thing I did was to delete the account (after writing down its two transactions, which I can add back in later).

The account -- even though deleted -- still showed in the category list as an "Expense." So my next step was to delete that Expense category - which was really an account that should have shown as "Transfer" in the "Type" field.

That fixed it. Now the New Category box is able to load all categories, and is not blocked by the entry that had listed an account as an Expense, rather than as a Transfer.

So: Look for any accounts (brokerage, bank, whatever) that are listed as "Expense" rather than as "Transfer" in the Type field of the category list. If one is there, it will block the Add Category drop down box from going past it to the next "real" expense.


This discussion has been closed.